Bug 470829 - traceback when submitting from firstboot
traceback when submitting from firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-11-10 09:57 EST by Jeremy Katz
Modified: 2008-11-13 11:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 11:50:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-11-10 09:57:20 EST
After installing a live image from a day or two ago, I elected to send my profile to smolt.  Since I didn't have a network connection available yet, this failed and the attached traceback was left on the console.  Basically, it looks like all of the error conditions just return an int instead of the tuple.  Which then means that the error case doesn't ever retry
Comment 1 Mike McGrath 2008-11-12 14:57:27 EST
This is the normal behaviour for no network connection.  I can fix the traceback so it doesn't throw an error but it will attempt to retry sometime during its monthly checkin.  I'm actually spending some time to get smolt in better shape, I'm not that experienced with what should and shouldn't be an F10 blocker but it seems this is a minor issue as the cron job will get run and send the profile in.
Comment 2 Fedora Update System 2008-11-12 17:00:08 EST
smolt-1.1.1.1-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/smolt-1.1.1.1-9.fc10
Comment 3 Mike McGrath 2008-11-12 17:01:28 EST
This is in and ready, i'm going to request a push of it from releng.  Additional testing is always appreciated.
Comment 4 Jeremy Katz 2008-11-13 11:50:04 EST
Looks good to me and tagged now.  Closing

Note You need to log in before you can comment on or make changes to this bug.