Bug 470855 - condor_schedd logs incorrect number of idle jobs
condor_schedd logs incorrect number of idle jobs
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.0
All Linux
medium Severity medium
: 2.2
: ---
Assigned To: Timothy St. Clair
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 11:54 EST by Matthew Farrellee
Modified: 2012-02-14 14:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-14 14:36:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2008-11-10 11:54:14 EST
Description of problem:

The condor_schedd logs about the number of idle jobs, but does so incorrectly.


Version-Release number of selected component (if applicable):

exists since at least 7.0.5


How reproducible:

Always


Steps to Reproduce:
1. start a clean schedd
2. monitor SchedLog
3. submit 512 jobs that do not run
4. in SchedLog, watch for: Out of servers - 0 jobs matched, 512 jobs idle, 1 jobs rejected
5. rm the jobs
6. in SchedLog, watch for: Out of servers - 0 jobs matched, 512 jobs idle, 0 jobs rejected


Expected results:

I would expect the log to mention 0 jobs idle when in fact there are 0 idle jobs.


Additional info:

This appears to be related to HashTable iteration. Possibly jobs are not being purged when they are removed from the queue. The jobs are counted by walking the queue with get_job_prio in qmgmt.C.
Comment 2 Timothy St. Clair 2012-02-14 14:36:57 EST
log delta is not the same anymore, match line appears differently post asyn negotiation.

Note You need to log in before you can comment on or make changes to this bug.