Bug 470858 - [PATCH] (mkinitrd) Move loadDrivers before plymouth --show-splash
[PATCH] (mkinitrd) Move loadDrivers before plymouth --show-splash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 11:59 EST by Warren Togami
Modified: 2008-11-18 21:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 21:55:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-loadDrivers-before-plymouth-show-splash-because-it.patch (1.33 KB, patch)
2008-11-10 12:00 EST, Warren Togami
no flags Details | Diff
0001-Ignore-if-missing-module-group-specified-in-with-a.patch (1.09 KB, patch)
2008-11-11 01:37 EST, Warren Togami
no flags Details | Diff

  None (edit)
Description Warren Togami 2008-11-10 11:59:58 EST
mkinitrd --with-avail="radeon" makes the module available in the initrd, and it gets loaded if the hardware matches pciid.

For now this is only used for modesetting on thin clients, since loadDrivers is run only if --with-avail is used.
Comment 1 Warren Togami 2008-11-10 12:00:44 EST
Created attachment 323095 [details]
0001-loadDrivers-before-plymouth-show-splash-because-it.patch
Comment 2 Jeremy Katz 2008-11-10 12:07:12 EST
The downside is that we then wait for those drivers to load before showing the splash which means you get the pretty boot "later".  Since it'll only affect thin clients right now, that's probably okay, but it's something to think about for how we load the modesetting drivers in F11 and later when we'll, eg want them in the live initrd case
Comment 3 Warren Togami 2008-11-10 12:14:43 EST
Yes, we discussed that downside, but agreed it was OK because this effects only thin clients for now.

For F11 I think maybe we need something like:
loadDrivers --modesetting
loadDrivers --networking
Comment 4 Warren Togami 2008-11-11 01:37:35 EST
Created attachment 323153 [details]
0001-Ignore-if-missing-module-group-specified-in-with-a.patch

Ignore if missing module group specified in --with-avail.  This matches the behavior if an individual module does not exist.  Without this patch it prints an ugly error message as the cat command tries to print a file that does not exist.

Trivial patch.
Comment 5 Peter Jones 2008-11-12 14:05:31 EST
These are applied in 6.0.71-1 .

Note You need to log in before you can comment on or make changes to this bug.