Bug 470869 - LANG=de_DE.UTF-8 sets language but not keyboard on Live CD
LANG=de_DE.UTF-8 sets language but not keyboard on Live CD
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 13:06 EST by probono
Modified: 2013-01-09 23:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 11:40:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description probono 2008-11-10 13:06:37 EST
Description of problem:
I need to set both language and keyboard to German on the Live CD by specifying boot options. However, it appears that it is not possible to set the keyboard this way.

Version-Release number of selected component (if applicable):
Fedora 10 Preview Live CD

How reproducible:
boot the live CD with LANG=de_DE.UTF-8

Actual results:
Language is German, keyboard is English

Expected results:
Language is German, keyboard is German

Additional info:
Ubuntu uses two separate boot arguments so that language and keyboard can be set independently of each other.
Comment 1 Bill Nottingham 2008-11-10 13:24:35 EST
Keyboard can't be assumed from language.
Comment 2 Matthias Clasen 2008-11-11 13:44:38 EST
It would probably be possible to extend the thing that currently parses LANG= from the kernel cmdline and make it parse KEYBOARD=... too

Unfortunately, I failed to locate the code that does that...
Comment 3 Matthias Clasen 2008-11-11 13:46:36 EST
gdm does look at /etc/sysconfig/keyboard 
to determine the default layout.
Comment 4 probono 2008-11-11 14:15:35 EST
/sbin/real-init on the initrd reads the language from the boot arguments and writes it to /sysroot/etc/sysconfig/i18n, so probably this would be the right place to do something similar for the keyboard as well.

Thanks for your consideration.
Comment 5 Jeremy Katz 2008-11-12 11:40:02 EST
Added support for booting with 'live_keytable=us' (or similar) which will set KEYTABLE=us in /etc/sysconfig/keyboard accordingly
Comment 6 probono 2008-11-12 11:46:48 EST
Perfect, thanks!
Comment 7 Jesse Keating 2008-11-12 13:58:53 EST
(In reply to comment #5)
> Added support for booting with 'live_keytable=us' (or similar) which will set
> KEYTABLE=us in /etc/sysconfig/keyboard accordingly

Added where, and is it tagged for f10?
Comment 8 probono 2008-11-25 18:26:17 EST
I have tried to add "live_keytable=de" to a Fedora 10 Live USB system and it works very well, I do get a German keyboard. 

Thank you for implementing this.

(There is a minor cosmetic glitch: In the GDM login window, it shows "USA" at the bottom of the screen as the keyboard setting where I'd expect it to show "German" because it is in fact set to German. Hopefully that GDM login window will go away altogether on the Live CD.)
Comment 9 probono 2010-02-14 05:05:44 EST
Looks like this doesn't work any more in Fedora 12?
Please let me know how to set keyboard and language to German in Fedora 12.

Note You need to log in before you can comment on or make changes to this bug.