Bug 470911 - Satellite Documentation: web.maximum_config_file_size and maximum_config_file_size
Satellite Documentation: web.maximum_config_file_size and maximum_config_file...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation (Show other bugs)
510
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Ha
Jeff Browning
: Documentation
Depends On:
Blocks: 456984
  Show dependency treegraph
 
Reported: 2008-11-10 15:41 EST by Issue Tracker
Modified: 2014-09-17 20:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:45:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2008-11-10 15:41:39 EST
Escalated to Bugzilla from IssueTracker
Comment 5 Xixi 2008-11-10 16:06:47 EST
*For Engineering*

Quick summary:

Currently we have 2 config parameters for maximum configuration file size -

/etc/rhn/default/rhn_server.conf:

# Maximum size for a config file
maximum_config_file_size = 131072

/etc/rhn/default/rhn_web.conf

# maximum size for a config file
web.maximum_config_file_size = 131072

The former is used in perl-based config file management - /usr/lib/perl5/site_perl/5.8.5/Sniglets/ConfigManagement.pm, whereas the latter is used in java-based UI config file management - code/src/com/redhat/rhn/common/conf/Config.java (see https://bugzilla.redhat.com/show_bug.cgi?id=433378#c2).

Only the latter - web.maximum_config_file_size is documented in the manual, and as it is you need to set both of the params for the back-end to work.

This BZ is intended to be a documentation bug, another one to be opened to consolidate the 2 parameters.

We need to make changes in 2 places.

1. The Satellite manual, e.g., https://www.redhat.com/docs/manuals/satellite/Red_Hat_Network_Satellite-5.1.0/html/Reference_Guide/configuration-files.html, only mentions web.maximum_config_file_size, until the 2 params are consolidated, it should probably mention maximum_config_file_size too.  It would also be nice to have a blurb on the maximum *UI-editable* config file size here (see bug 433378).

2. Satellite conf files, until the 2 params are consolidated, should distinguish between the two, or at least refer to each other in the comments as they're in separate files.

/etc/rhn/default/rhn_server.conf:
/etc/rhn/default/rhn_web.conf
Comment 7 Xixi 2008-11-10 16:22:59 EST
(In reply to comment #5)
> This BZ is intended to be a documentation bug, another one to be opened to
> consolidate the 2 parameters.
bug 470922
Comment 9 John Ha 2008-12-23 15:17:54 EST
Here's a first swipe at changing the passage at this URL:

https://www.redhat.com/docs/manuals/satellite/Red_Hat_Network_Satellite-5.1.0/html/Reference_Guide/configuration-files.html

 By default, the maximum file size for confiugration files is 128KB. If you
 need to change that value, find and modify the following line in the 
 /etc/rhn/default/rhn_web.conf file:

  web.maximum_config_file_size=128

 You must also find and change the following line in the 
 /etc/rhn/default/rhn_server.conf file to the same value:

  maximum_config_file_size=128

 Change the value in both files from 128 to the desired value in kilobytes.
Comment 12 Jeff Browning 2009-04-27 18:07:56 EDT
Verified
Comment 13 Sayli Karmarkar 2009-08-03 11:58:42 EDT
 By default, the maximum file size for configuration files is 128KB. If you need to change that value, find and modify the following line in the /etc/rhn/default/rhn_web.conf file:

web.maximum_config_file_size=128

You must also find and change the following line in the /etc/rhn/default/rhn_server.conf file to the same value:

maximum_config_file_size=128

Change the value in both files from 128 to the desired value in kilobytes. 

Moving to release_pending.
Comment 14 Brandon Perkins 2009-09-10 16:45:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html
Comment 16 Xixi 2011-02-04 15:23:54 EST
Opening BZ to public so it's more visible.

Note You need to log in before you can comment on or make changes to this bug.