This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 470939 - Boot on batery power is VERY slow
Boot on batery power is VERY slow
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 18:04 EST by Alan Olsen
Modified: 2013-01-10 02:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 14:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
acpidump from slow booting system (183.78 KB, text/plain)
2008-11-10 19:53 EST, Alan Olsen
no flags Details
lspci output for HP Pavilion DV6000 (8.62 KB, text/plain)
2008-11-11 19:30 EST, Alan Olsen
no flags Details

  None (edit)
Description Alan Olsen 2008-11-10 18:04:30 EST
Description of problem:

Booting rawhide on my HP laptop on betery power takes 18 minutes from drive encryption password entry to GDM starting.  This did not happen with Fedora 9.  With the power plug it takes a little over 3 minutes for the same boot process.

Version-Release number of selected component (if applicable): Any of the 2.6.27 kernels.


How reproducible:


Steps to Reproduce:
1. Pull plug
2. Boot
3. Wait and wait and wait.
  
Actual results:
18 minute wait

Expected results:
About a 3 minute wait.

Additional info:

I am thinking this might be the CPU not throttling up to full power during boot if on battery power.  The system is a dual core Turion-64 TL-68 with 4 gigs of ram.  The processor goes from 800mhz to 2.4 ghz.  It should not take this long on boot.
Comment 1 Dave Jones 2008-11-10 18:48:14 EST
wtf.. even if it was stuck at 800mhz, it should still boot way faster than that.
I suspect ACPI or timer shenanigans.

mjg59 &  tglx, any ideas?
Comment 2 Matthew Garrett 2008-11-10 19:16:25 EST
Can you attach the output of the acpidump command in the pmtools package?
Comment 3 Alan Olsen 2008-11-10 19:53:26 EST
Created attachment 323139 [details]
acpidump from slow booting system

Here is the requested dump.  If you need anything else, just ask.
Comment 4 Matthew Garrett 2008-11-10 20:07:11 EST
Ok. If you boot without the rhgb boot argument, does it stop at any particular part of the boot process or is it slow throughout?
Comment 5 Alan Olsen 2008-11-11 11:57:43 EST
It is slow throughout.  Every part of the init process takes a very long time.
Comment 6 Chuck Ebbert 2008-11-11 18:59:42 EST
Exactly what model of HP notebook is this?

Also please post the output of the 'lspci -vnn' command.
Comment 7 Chuck Ebbert 2008-11-11 19:09:14 EST
Should be fixed in 2.6.27.5-100. But please post the requested information.

Also, try adding:

  acpi_skip_timer_override

to the kernel boot options.
Comment 8 Alan Olsen 2008-11-11 19:30:33 EST
Created attachment 323279 [details]
lspci output for HP Pavilion DV6000
Comment 9 Alan Olsen 2008-11-11 19:46:01 EST
I tried the boot on battery and with the acpi_skip_timer_override.

One minute and 26 seconds.  That is half the speed of what it was before while plugged in.

MUCH better.

I will test the new kernel once it hits rawhide.  (Whatever mirror I wind-up hitting with yum.)
Comment 10 Chuck Ebbert 2008-11-19 16:46:12 EST
Does the latest kernel work without having to use the boot option?
Comment 11 Alan Olsen 2008-11-19 17:31:10 EST
-110 boots.  -113 does not.  -113 get stuck after issuing a timer unstable message.
Comment 12 Alan Olsen 2008-11-19 22:01:20 EST
-117 does not boot either.  -110 I get a "waiting 10 seconds" message.  It does not get to that message for the -113 and -117 kernels.
Comment 13 Bug Zapper 2008-11-26 00:09:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Alan Olsen 2008-12-30 14:02:42 EST
This problem still exists.

The kernels before  2.6.27.5-101.fc10.x86_64 would boot slowly, but they would boot.  2.6.27.5-101.fc10.x86_64 works.  Anything after that stalls out and does not boot.  (The kernel is still alive, but it just sits and spins.)  I have tried everything up through 2.6.27.9-159.fc10.x86_64.  2.6.27.5-101.fc10.x86_64 is the last usable kernel on this system.

What details do you need to resolve this?
Comment 15 Alan Olsen 2009-06-29 14:05:29 EDT
I have a solution to this problem.

The HP dv6700 has a bug in the bios. The problem exists in BIOS revision F.2.  

Solution: Upgrade the BIOS and the problem is resolved.

(Upgrading is a pain in itself. Requires having Windows. I had to buy a new harddrive and reinstall Windows to that to get the bios updater to run.)

Note You need to log in before you can comment on or make changes to this bug.