Bug 470967 - sub-title is used as the menu item for books
sub-title is used as the menu item for books
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 23:41 EST by Darrin Mison
Modified: 2010-11-23 22:57 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.39
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 23:17:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darrin Mison 2008-11-10 23:41:55 EST
Description of problem:
When a cocument RPM is installed the title of the GNOME menu item for that book Book is the sub-title of the book, not the title.  It should be the book title.

Version-Release number of selected component (if applicable):
0.38

How reproducible:
every time

Steps to Reproduce:
1. in Book_info.xml
<title>The Hobbit</title>
<subtitle>Or there and back again</subtitle>

2. make web-brew-en-US
3. download rpm, install & check menu

Actual results:
GNOME menu item title is: "Or there and back again"

Expected results:
GNOME menu item title is: "The Hobbit"

Additional info:
Comment 1 Jeff Fearn 2008-11-11 23:17:42 EST
Changed display name to "product productnumber: title"
Changed popup text to "subtitle"

This format was chosen because:

1: It is valid to have have the same book from multiple versions of a product installed.

e.g.

You can have the Deployment Guide for RHDS 7.1 and RHDS 8.0 installed at the same time.


2: It is also valid to use the same title for books from multiple products.

e.g.

It is valid for RHDS and RHEL to both have a book named Deployment Guide.
Comment 2 Fedora Update System 2009-01-14 21:56:48 EST
publican-0.39-0.fc9, publican-fedora-0.16-0.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.