Bug 471002 - vmalloc error when starting second X server
vmalloc error when starting second X server
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 05:50 EST by Mads Kiilerich
Modified: 2009-03-06 09:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 09:01:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.1.log (67.17 KB, text/plain)
2008-11-11 05:51 EST, Mads Kiilerich
no flags Details
/var/log/dmesg (40.34 KB, text/plain)
2008-11-11 05:52 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2008-11-11 05:50:42 EST
Description of problem:

When selecting Other from Fast User Switcher then the X on tty7 failed to start:

Xorg.1.log:
adding fb map from cef1b000 for 6ec000 ret 0 cef1b000
front handle is 6
failed to get old fb, id 20

messages:
Nov 11 11:38:36 dev-mk kernel: allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
Nov 11 11:38:36 dev-mk kernel: [drm:drm_bo_evict] *ERROR* Buffer eviction failed
Nov 11 11:38:36 dev-mk kernel: [drm:drm_buffer_object_validate] *ERROR* Failed moving buffer.
Nov 11 11:38:36 dev-mk kernel: [drm:drm_buffer_object_validate] *ERROR* Out of aperture space or DRM memory quota.
Nov 11 11:38:36 dev-mk kernel: mtrr: base(0xcef1b000) is not aligned on a size(0xb13000) boundary
Nov 11 11:38:36 dev-mk kernel: [drm:drm_mode_getfb] *ERROR* invalid framebuffer id

This might be related to my closed reports:
Bug 468389 -  Loading R500 Microcode nomodeset => BUG: unable to handle kernel NULL pointer 
Bug 468975 -  System hanging on (II) RADEON(0): [RESUME] Attempting to re-init Radeon hardware.

Version-Release number of selected component (if applicable):

kernel-2.6.27.5-92.fc10.i686 modeset
xorg-x11-drv-ati-6.9.0-44.fc10.i386 no xorg.conf
Comment 1 Mads Kiilerich 2008-11-11 05:51:57 EST
Created attachment 323167 [details]
/var/log/Xorg.1.log

Forgot to say: No compiz
Comment 2 Mads Kiilerich 2008-11-11 05:52:23 EST
Created attachment 323168 [details]
/var/log/dmesg
Comment 3 Mads Kiilerich 2008-11-13 17:10:49 EST
airlied: oh I need to test fast-user-switch some more...
airlied: yes starting the second X server might cause problems
airlied: switching back to the first server is possibly broken.

airlied: yup.. so I guess I'll play with switching once I get the current bits done.
airlied: pretty much from what I can see.
airlied: I'll play around today/tomorrow and see what I can fix.
Comment 4 Bug Zapper 2008-11-26 00:10:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Dave Airlie 2008-12-08 22:41:15 EST
Is this still happening with -61 and -137 kernel?
Comment 6 Mads Kiilerich 2008-12-09 19:39:19 EST
ATI & KMS has improved a lot, thanks! But because of bug 466598 I can't use KMS on a daily basis and thus can't give it heavy testing right now. But I will leave it assigned and come back to it soon.
Comment 7 Mads Kiilerich 2008-12-11 20:09:55 EST
Some testing shows that it seems to work OK. But I couldn't reproduce it on demand before, so my testing doesn't prove much. If you think it is solved then please close it - I will reopen if I see it again.

BUT then I switched to a user who had compiz. At first it worked fine, but when I switched back to non-compiz I got horrible corruption. Big tiles had been moved around. I don't know if this is related ...
Comment 8 Mads Kiilerich 2009-03-06 09:01:35 EST
That is long time ago, things have changed, and this report no longer has any value. 

Closing.

Note You need to log in before you can comment on or make changes to this bug.