Bug 471011 - pytz should use system-wide zoneinfo data
pytz should use system-wide zoneinfo data
Status: CLOSED DUPLICATE of bug 471010
Product: Fedora
Classification: Fedora
Component: pytz (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 07:04 EST by Petr Machata
Modified: 2015-05-04 21:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 03:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Machata 2008-11-11 07:04:42 EST
Description of problem:
It's necessary to update pytz to more recent version, current 2006p is ancient by tzdata standards.  To avoid having to rebase every time Olson database changes, pytz should use tzdata files instead of its own.  It might be possible to even not ship pytz own data, and simply use tzdata always.

Version-Release number of selected component (if applicable):
pytz-2006p-3.fc9.noarch

How reproducible:
Always.

Steps to Reproduce:
$ rpm -ql tzdata | grep Salta
/usr/share/zoneinfo/America/Argentina/Salta
/usr/share/zoneinfo/posix/America/Argentina/Salta
/usr/share/zoneinfo/right/America/Argentina/Salta
$ python -c 'import pytz; pytz.timezone("America/Argentina/Salta")'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/pytz/__init__.py", line 71, in timezone
    raise KeyError, zone
KeyError: 'America/Argentina/Salta'
  
Actual results:
New zones are not available, the existing ones are presumably not current.

Expected results:
pytz is kept in sync with tzdata.

Additional info:
I've had a chat with pytz maintainer, and he told me that new versions of pytz already have a support in place that makes it possible to not use pytz own zoneinfo data, and supply system-wide instead.  Debian are reportedly doing just that.  It would be a very desirable feature to have in Fedora, too.
Comment 1 Felix Schwarz 2009-04-13 03:46:12 EDT
This is a duplicate of bug 471010

*** This bug has been marked as a duplicate of bug 471010 ***

Note You need to log in before you can comment on or make changes to this bug.