Bug 471017 - gnumeric rawhide can't open XLS files
gnumeric rawhide can't open XLS files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-11-11 07:51 EST by Peter Robinson
Modified: 2008-11-17 06:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 06:36:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
No option to save as excel (439.45 KB, image/png)
2008-11-17 06:03 EST, Peter Robinson
no flags Details
works for me (137.21 KB, image/png)
2008-11-17 06:13 EST, Huzaifa S. Sidhpurwala
no flags Details

  None (edit)
Description Peter Robinson 2008-11-11 07:51:33 EST
Description of problem:

gnumeric can't open .xls (microsoft excel) files. Fedora 9 version could open them without issue

Version-Release number of selected component (if applicable):
gnumeric-1.8.2-2.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Try to open xls file
2. Get unsupported format error
3.
  
Actual results:
Get unsupported format error

Expected results:
File opens

Additional info:

It seems the package hasn't been rebuilt for F-10. I tried a simple F-10 rebuild in koji to see if that would resolve the issue (http://koji.fedoraproject.org/koji/taskinfo?taskID=926137) but to no avail. Not sure what else has changed since then. I use gnumeric extensively as its a more lightweight than oo.org for simple spreadsheets. There's also version 1.8.3 out
Comment 1 Huzaifa S. Sidhpurwala 2008-11-17 05:32:39 EST
Works for me.
When i open my xls doc it says "Invalid MS Proprietary section"
but opens the xls file.

I am using one from:

http://koji.fedoraproject.org/koji/buildinfo?buildID=69958

Can you attach the xls file you are using please.
Comment 2 Peter Robinson 2008-11-17 06:03:46 EST
Created attachment 323755 [details]
No option to save as excel

Unfortunately I can't provide a copy of the spreadsheets I use. But I'll attach a screen shot as you can't even save a new spreadsheet as excel. I'm not sure if its because I'm missing a library that it needs. I've also tried with the build you provided from koji above.
Comment 3 Huzaifa S. Sidhpurwala 2008-11-17 06:12:41 EST
Works for me.
Working a book in xls format is working, if that is what you meant.
Comment 4 Huzaifa S. Sidhpurwala 2008-11-17 06:13:43 EST
Created attachment 323756 [details]
works for me
Comment 5 Huzaifa S. Sidhpurwala 2008-11-17 06:16:19 EST
Can you please check this for me please.
I have the excel libraries:

[huzaifas@dhcp1-72 ~]$ rpm -ql gnumeric | grep excel
/usr/lib/gnumeric/1.8.2/plugins/excel
/usr/lib/gnumeric/1.8.2/plugins/excel/excel.so
/usr/lib/gnumeric/1.8.2/plugins/excel/plugin.xml
Comment 6 Peter Robinson 2008-11-17 06:30:41 EST
OK, it appears for some reason on a clean install all the plugins were disabled. Once I enabled them it now works OK.
Comment 7 Huzaifa S. Sidhpurwala 2008-11-17 06:36:25 EST
Strange i did a clean install too and none of them were disabled.

Closing this anyways.

Note You need to log in before you can comment on or make changes to this bug.