Bug 471103 - Font spacing wrong in menus and text
Font spacing wrong in menus and text
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 14:50 EST by Gérard Milmeister
Modified: 2009-01-14 22:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:03:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Openoffice menu font spacing (15.86 KB, image/png)
2008-11-11 14:50 EST, Gérard Milmeister
no flags Details
Firefox menu font spacing (9.95 KB, image/png)
2008-11-11 14:51 EST, Gérard Milmeister
no flags Details
Original Openoffice menu font (10.65 KB, image/png)
2008-11-12 12:05 EST, Gérard Milmeister
no flags Details
Openoffice with DejaVu Sans font (54.66 KB, image/png)
2008-11-13 12:57 EST, Gérard Milmeister
no flags Details
what I see (171.95 KB, image/png)
2008-11-13 18:07 EST, Caolan McNamara
no flags Details
again, what I see with "slight" (189.39 KB, image/png)
2008-11-14 04:50 EST, Caolan McNamara
no flags Details
yeah, confirmed (6.60 KB, image/png)
2008-11-17 05:05 EST, Caolan McNamara
no flags Details
screenshot of that version with same setting as previous screenshot (209.38 KB, image/png)
2008-11-23 09:45 EST, Caolan McNamara
no flags Details
Openoffice and Gedit (450.41 KB, image/png)
2008-11-23 14:35 EST, Gérard Milmeister
no flags Details
Tracked down a Zurich-BT font (228.64 KB, image/png)
2008-11-24 07:07 EST, Caolan McNamara
no flags Details
There's clearly a difference from your one to mine, but... (4.80 KB, image/png)
2008-11-24 07:09 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 64508 None None None Never
OpenOffice.org 88303 None None None Never
Launchpad 256058 None None None Never

  None (edit)
Description Gérard Milmeister 2008-11-11 14:50:43 EST
Created attachment 323225 [details]
Openoffice menu font spacing

In Gnome, the character spacing in menu and text is wrong,
although throughout other Gnome, GTK and KDE applications
is OK. This can be clearly seen in the attached screenshots
of Openoffice and Firefox.
Comment 1 Gérard Milmeister 2008-11-11 14:51:38 EST
Created attachment 323226 [details]
Firefox menu font spacing
Comment 2 David Tardon 2008-11-12 01:43:28 EST
Frankly I don't see where is the problem there. I've never noticed that and I bet most of other users haven't too.

Btw, gEdit uses bigger font than Firefox; is that a bug too?
Comment 3 Gérard Milmeister 2008-11-12 12:05:31 EST
Created attachment 323353 [details]
Original Openoffice menu font
Comment 4 Gérard Milmeister 2008-11-12 12:06:12 EST
The attached screenshot of openoffice (official release)
installed instead of the Fedora one on the same machine shows
a clear difference in the rendering of the menu font. Especially
observe the spacing of the "Tools" menu and the font input field.
Because of this difference I feel right in assuming that this
might be a bug due to a patch applied to the Fedora build.
Comment 5 Caolan McNamara 2008-11-12 18:24:33 EST
It is true that the OOo layout is done with icu, not pango. And the vanilla 2.3 release has a different icu version built-in (though 3.1 will have the same as in fedora) than the fedora one, and the vanilla freetype is slightly different to the fedora one. And is is true that the fedora OOo has extra mojo to honour extra fontconfig flags than the vanilla one, which should make it closer in layout to generic GNOME apps rather than further away,

So the interesting comparison is not between fedora OOo and vanilla OOo or firefox, but between fedora OOo and e.g. gedit

icu and pango layout ever-so-slightly differently. To make a determination if you have a bug here or not then what I need to know is.

a) what settings you have in system->preferences->look and feel->appearance->fonts
b) The output of fc-match "<fontname>" if it is something generic like Sans
Comment 6 Gérard Milmeister 2008-11-13 12:57:21 EST
Created attachment 323484 [details]
Openoffice with DejaVu Sans font
Comment 7 Gérard Milmeister 2008-11-13 12:57:39 EST
For this screenshot I set the Application font to "DejaVu Sans Book" (9pt)
instead of my usual choice "Zurich BT". At first it seems to look
a little better, but in the screenshot you see for example in the
File menu the wrong spacing of "Digital Signatures" or "Templates".
Also in the text window "jumps" and lazy.
Comment 8 Caolan McNamara 2008-11-13 18:07:03 EST
Created attachment 323509 [details]
what I see
Comment 9 Gérard Milmeister 2008-11-14 04:23:25 EST
Usually I have set font hinting to slight, since with this
setting font rendering of ZurichBT (which is Bitstream's
version of Univers) looks good. If I use DejaVu and set
set font hinting to medium ,the Openoffice rendering looks
indeed better, if not completely right. So, as you said,
the differences between icu and pango layout seem to have
to take the blame. I would expect that if everything looks
fine in all other applications, it should also in
Openoffice (and there is still the fact, that with the
official openoffice.org build, this is the case).
I usually use Latex for my texting needs, and therefore
I might be a little spoilt :-)
Comment 10 Caolan McNamara 2008-11-14 04:50:53 EST
Created attachment 323559 [details]
again, what I see with "slight"

Do you think you could set up a screenshot like this one, where the settings and fonts you are using are visible ?

Again I don't see a problem when I tweak on "slight".
Comment 11 Gérard Milmeister 2008-11-16 16:23:11 EST
With these settings (in your screenshot) it looks indeed better, but
yet is not right. For example, look at "Digital" where there is too
much space between "D" and "i". Or "Properties", "o" and "p" are too
far away each other, while "p" and "e" are very close. Or the space
between "P" and "r" in "Print...". The look as a whole has a shaky
quality.

BTW, I noticed also spacing problems in the Abiword text area (while
the interface font is OK).

The worst thing about this is, that wrong spacing is visible
in the printed (or PDF) result.
Comment 12 Gérard Milmeister 2008-11-16 17:00:58 EST
I found an Ubuntu bug that reports something similar.
Comment 13 Caolan McNamara 2008-11-17 05:05:38 EST
Created attachment 323751 [details]
yeah, confirmed

Indeed with "Properties" in DejaVu Sans at 9pt, OOo vs e.g. gedit I can see that we're rendering each glyph exactly the same, but that the lower-case p is offset poorly.
Comment 14 Caolan McNamara 2008-11-17 11:33:30 EST
Getting a hint_medium back from fontconfig, but we want to actually get a hint slight back from cairo. Works by default in vanilla as honouring fontconfig options setting per-font hints isn't supported and hint_slight is hard-coded. In fedora we're currently falling between stools in taking the fontconfig defaults without overriding them with the cairo ones in the normal case of not having a specific per-font override. So we really need to wedge in a cairo_ft_options_substitute in there.
Comment 15 Caolan McNamara 2008-11-18 07:18:46 EST
fix checked into F-10 and rawhide
Comment 16 Caolan McNamara 2008-11-20 04:24:43 EST
I'll build a test update for F-9 as well. will be >= 2.4.2-18.2
Comment 17 Gérard Milmeister 2008-11-23 07:43:49 EST
I installed 2.4.2-18.2 directly from Koji. Unfortunately
there is no visible improvement to the font spacing in
the menus.
Comment 18 Caolan McNamara 2008-11-23 09:45:05 EST
Created attachment 324434 [details]
screenshot of that version with same setting as previous screenshot

Looked better I felt. i.e. spacing of "Properties" looks the same as the same string in the same font within gedit, no ? Still seeing some visible problems in that screenshot vs what you'd get in e.g. gedit or some other application ?
Comment 19 Gérard Milmeister 2008-11-23 14:35:41 EST
Created attachment 324442 [details]
Openoffice and Gedit

Screenshot showing Openoffice and Gedit with the font settings dialog.

Compare the "Tools" menu on both, also the spacing of jumps in
the Openoffice text area, "Digital Signature", any many others.
Comment 20 Caolan McNamara 2008-11-24 07:07:56 EST
Created attachment 324466 [details]
Tracked down a Zurich-BT font
Comment 21 Caolan McNamara 2008-11-24 07:09:46 EST
Created attachment 324467 [details]
There's clearly a difference from your one to mine, but...
Comment 22 Gérard Milmeister 2008-11-24 12:24:30 EST
Yes, looks correct. But what can then be problem?
Comment 23 Gérard Milmeister 2008-11-24 13:30:05 EST
Ok, I found the problem! I had still a .fonts.conf file in
my home directory (probably from an earlier installation),
which among others, contained a setting of hintmedium.
I removed it, now everything seems to look like your screenshot.
I am not sure whether the rendering in text area is
completely right, but it is definitely an improvement.
In any case rendering settings should not affect printing...
Well, at least the Cairo issue was worth the bug report.
Thanks for your patience.
Comment 24 Caolan McNamara 2008-11-24 17:43:46 EST
We currently don't have a concept of propagating down the type of surface the font will be used on, i.e. the screen or postscript output, for selection of what hints should be used. Once a font has been opened, then the setting used for it sticks while its in the cache, regardless of the surface. Might be interesting to separate it per surface type and e.g. have the base fontconfig settings affect all surfaces, but those extra cairo ones just the screen and default towards "slight" for printing. Must have a look to see what the rest of the desktop does. But at least we've made an improvement here on consistently on honouring the user-visible global settings.
Comment 25 Fedora Update System 2008-12-19 04:32:47 EST
openoffice.org-2.4.2-18.3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/openoffice.org-2.4.2-18.3.fc9
Comment 26 Fedora Update System 2008-12-21 03:34:20 EST
openoffice.org-2.4.2-18.3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11549
Comment 27 Fedora Update System 2009-01-14 22:03:12 EST
openoffice.org-2.4.2-18.3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.