Bug 471143 - Blender crashes when changing desktops
Blender crashes when changing desktops
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 18:23 EST by Ben Boeckel
Modified: 2009-09-24 04:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 20:32:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2008-11-11 18:23:18 EST
Description of problem:
When changing desktops (I'm running KDE4 if it's relevent) while running Blender, it crashes when I change to another desktop.

Version-Release number of selected component (if applicable):
blender-2.47-5.fc9.x86_64

How reproducible:
Very (didn't happen once, but hasn't not crashed since then).


Steps to Reproduce:
1. Open Blender
2. Change virtual desktop
3. Blender isn't there when returning
  
Actual results:
Blender disappears with the following output to the terminal:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  73 (X_GetImage)
  Serial number of failed request:  352
  Current serial number in output stream:  352


Expected results:
Blender should keep running on the other desktop
Comment 1 Jochen Schmitt 2008-11-13 10:30:51 EST
It may be nice, if you can tryout the blender-2.48a package.
Comment 2 Jochen Schmitt 2008-11-13 11:32:06 EST
I have tried to reproduced your issue with blender-2.48a.

I couldn't rise a crash, so I will close this bug.

Please update to blender-2.48a.
Comment 3 Ben Boeckel 2008-11-13 16:36:00 EST
I tried 2.48a and it still occurs. Different error this time:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  42 (X_SetInputFocus)
  Serial number of failed request:  226
  Current serial number in output stream:  227

The (or one) trigger seems to be if you change desktops as the window appears (start in terminal and immediately change to another desktop as blender starts drawing). It may be something different, but it guarantees a crash here.
Comment 4 Jochen Schmitt 2008-11-16 15:54:33 EST
I'm very unhappy to hear this. Unfortunately, I'm unable to reproduce you reported bug, so I have to asume, that this is an issue with your graphic adapter.

Question: Which graphic adapter do you use?

I'm using the properitary graphic driver from nvidia (177.82).
Comment 5 Ben Boeckel 2008-11-16 18:58:59 EST
I'm using the nv driver.

$ rpm -q xorg-x11-drv-nv xorg-x11-server-common
xorg-x11-drv-nv-2.1.8-1.fc9.x86_64
xorg-x11-server-common-1.5.2-3.fc9.x86_64

I know it's not up to date with the latest of the nv driver, but it has problems of its own (DPI I suspect; fonts are bigger than they should be)
Comment 6 Jochen Schmitt 2008-12-02 14:40:00 EST
> $ rpm -q xorg-x11-drv-nv xorg-x11-server-common
> xorg-x11-drv-nv-2.1.8-1.fc9.x86_64
> xorg-x11-server-common-1.5.2-3.fc9.x86_64

I would to suggest, that you may try out the properitary nvidia driver from rpmfusion. For Blender it's very important, that the driver has a very good OpenGL support. AFAIK the nv driver doesn't fullfill this requirement.
Comment 7 Jochen Schmitt 2008-12-11 13:31:24 EST
I have close this bug, becouse from my experience this is a issue with the open source nv grapich driver.
Comment 8 Kevin Kofler 2008-12-11 18:47:30 EST
Then it should be reassigned, not closed.
Comment 9 Matěj Cepl 2008-12-19 18:47:23 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 10 Ben Boeckel 2008-12-19 20:32:48 EST
After updating to F10 (using xorg-x11-server-common-1.5.3-6.fc10.x86_64), it seems to have be fixed. Will reopen if it occurs again. Thanks.
Comment 11 Jeremy Gold 2009-09-24 04:02:25 EDT
Hope this isn't too far off topic, but found this bug because I was having a similar problem, and thought I'd add my findings.

I'm running Gentoo, with evilwm as window manager, and if I run blender in a minimized (i.e. not full screen) window, with a portion of the window off the screen, I get this error every time as soon as I type b (box-select). If I ensure that the window is either maximized (full screen), or fully within the desktop area, the problem does not occur.

Hope this helps...

Note You need to log in before you can comment on or make changes to this bug.