Bug 471191 - Upgrade to 1.6.x-releases
Upgrade to 1.6.x-releases
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: zabbix (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 04:47 EST by Stefan Neufeind
Modified: 2008-11-12 07:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 07:44:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-11-12 04:47:01 EST
Currently there is 1.4.6 in the repos. 1.6.x-series (meanwhile stable) is a large step forward. It would be great if updated packages could be created for Fedora - and then also be pushed as updates for epel (via separate ticket maybe).
Comment 1 Dan Horák 2008-11-12 05:10:28 EST
1.6.1 is already built for F-10, but any "backporting" to F-9 or EPEL depends on how smooth is the upgrade between 1.4 and 1.6 - compatibility of config files, upgrade of the database schema, etc. I think Jeff will have some answers.
Comment 2 Jeffrey C. Ollie 2008-11-12 07:44:34 EST
Upgrading to 1.6.x requires some non-trivial database schema updates, plus the 1.6.x releases are still unstable relative to 1.4.x (even though 1.6.1 seems to be a major improvement) so 1.6.x will definitely not make it into EPEL 5, and I'm unlikely to backport it to F-9 or F-8.  If you really want 1.6.x for any of those releases it's trivial to recompile the SRPMs from F-10 or rawhide and put them in a private repository (I've done that for my monitoring system at my $DAYJOB).
Comment 3 Stefan Neufeind 2008-11-12 07:51:20 EST
Okay, I see upgrading is a major issue. Then maybe how about a package "zabbix16" for the 1.6-release in Fedora 9 (8 will be closed soon anyway) and maybe that for EPEL as well? An upgrade Fedora 9 to Fedora 10 would then need to have a statement "zabbix replaces zabbix16" in the RPM. This way people wouldn't necessarily have to upgrade, but be able to install it from the repos. And if "zabbix conflicts with zabbix16" then we don't have a problem of parallel installs or so imho.

Note You need to log in before you can comment on or make changes to this bug.