Bug 471209 - Can't see wireless network that is using channel 12 or 13 using Intel 3945
Can't see wireless network that is using channel 12 or 13 using Intel 3945
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
medium Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 07:29 EST by Maurice
Modified: 2008-12-05 08:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 08:11:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (349 bytes, text/x-log)
2008-11-12 07:47 EST, Maurice
no flags Details
wpa_supplicant -dd output, while trying to connect to MOZ877W (4.33 KB, text/x-log)
2008-11-12 07:49 EST, Maurice
no flags Details
wpa_supplicant with -ddtt (9.76 KB, text/plain)
2008-11-17 10:27 EST, Maurice
no flags Details
wpa_supplicant with -dddt (13.30 KB, text/plain)
2008-11-17 11:35 EST, Maurice
no flags Details
iwlist output from Ubuntu 8.04 where I can see my AP (1.30 KB, text/plain)
2008-11-18 12:07 EST, Maurice
no flags Details

  None (edit)
Description Maurice 2008-11-12 07:29:14 EST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

I cannot see or connect to my wireless network which is using WPA2 Personal from Network Manager in Fedora 10. I can see my neighbors access points, but they are all using WEP. I've got a HP 6710b, lspci shows that I'm using Intel 3935ABG Rev 02, lsmod show that I'm using iwl3945.

This was working fine on Beta 1, but somewhere along the way an update has killed it, so I reverted back to Ubuntu 8.04. 

I've just checked on the live CD preview release and it's still the same.

Reproducible: Always

Steps to Reproduce:
1. Boot up 
2. Open Network Manager
3. No WPA networks are available.
Comment 1 Maurice 2008-11-12 07:47:56 EST
Created attachment 323327 [details]
dmesg output
Comment 2 Maurice 2008-11-12 07:49:02 EST
Created attachment 323328 [details]
wpa_supplicant -dd output, while trying to connect to MOZ877W
Comment 3 Dan Williams 2008-11-16 08:10:34 EST
Could you grab a new log with "-dddt" debug options?  Just "-dd" isn't quite verbose enough.
Comment 4 Maurice 2008-11-17 10:27:39 EST
Created attachment 323773 [details]
wpa_supplicant with -ddtt
Comment 5 Maurice 2008-11-17 10:29:07 EST
FYI, I've also tried a Ubuntu 8.10 live CD and I've got the same problem there, I can only see WEP enabled AP's
Comment 6 Dan Williams 2008-11-17 11:11:25 EST
Hmm, is that log with "-dddt" (ie, 3 'd' and 1 't')?  Still doesn't look quite verbose enough...
Comment 7 Maurice 2008-11-17 11:35:04 EST
Created attachment 323778 [details]
wpa_supplicant with -dddt

Hopefully the correct attachment this time, sorry I didn't read your first request properly.
Comment 8 Dan Williams 2008-11-17 17:01:48 EST
Yeah, the driver is simply unable to see the AP with scans.  The Ap is supposed to be 'MOZ877W', right?

Can you do the following?

1) /sbin/service NetworkManager stop
2) killall -TERM wpa_supplicant
3) ifconfig wlan0 up
4) iwlist wlan0 scan essid MOZ877W
5) after the results come in, check if MOZ877W shows up in the results
6) if not, wait 5 seconds, then do go back to step 4 again

Basically, if the AP isn't showing up in the scan results from the driver, NM won't be able to see it either.  Then it's either an AP bug, or a driver bug.
Comment 9 Maurice 2008-11-18 06:28:55 EST
Hi Dan,

I've done the above and I still can't see my AP (MOZ877W), I think the driver it's using is iwl3945 (from lsmod).

On Ubuntu 8.04 where it is working, I can see my AP using iwlist, it's using iwl3945, but it's also got iwlwifi_mac80211 loaded, I don't know if this is relevant.

I've also tried the first beta of F10 and it's not working there either, so my info above about it been broken by a update since the first beta is wrong.

Does this bug need to be moved to another component ?

Maurice
Comment 10 Dan Williams 2008-11-18 10:20:28 EST
Yeah, over to kernel.  Can you grab the 'iwlist wlan0 scan' output from Ubuntu (where you can see it) and paste it into this report?  Feel free to xx-out the AP's MAC address if you like.  It's useful to see what capabilities the AP is reporting.

Do you know what brand and model the AP is?
Comment 11 Maurice 2008-11-18 12:07:26 EST
Created attachment 323929 [details]
iwlist output from Ubuntu 8.04 where I can see my AP
Comment 12 Maurice 2008-11-18 12:11:23 EST
The AP is a Cisco 877W, I can connect to this using WPA on older versions of Fedora (F8 was the last one that I know of) Windows, Ubuntu 8.04 (but not 8.10).
Comment 13 Bug Zapper 2008-11-26 00:14:46 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Maurice 2008-11-27 05:54:46 EST
I've realised that this problem is down to the channel selection, the AP has chosen channel 13 automatically, I changed it to use Channel 1 (without realising) when adding a GuestWLAN and I can see it now.

If configure the router to use channel 1 to 11 it's fine, if I choose 12 or 13 it doesn't work.

As I can see the router using channel 12 and 13 in Ubuntu 8.04 and Windows XP, I would still consider it a bug, but I'm ok now so I've changed the priority to low.

If you need more info then I'm happy to help.

Maurice
Comment 15 John W. Linville 2008-12-01 10:05:39 EST
Please add the following to /etc/modprobe.conf:

   options cfg80211 ieee80211_regdom="EU"

Then reboot.  Do you find that you can see channels 12 and 13 now?
Comment 16 Maurice 2008-12-05 07:58:42 EST
Creating a modprobe.conf with 

options cfg80211 ieee80211_regdom="EU" 

allows me to see both channel 12 and 13.

Maurice
Comment 17 John W. Linville 2008-12-05 08:11:34 EST
Excellent!  FWIW, we (or at least I) hope to have a more friendly alternative for configuring this available in F11.

Note You need to log in before you can comment on or make changes to this bug.