Bug 471217 - udevsettle fails during boot
udevsettle fails during boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 09:21 EST by Patrick O'Callaghan
Modified: 2009-12-18 01:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:49:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick O'Callaghan 2008-11-12 09:21:53 EST
Description of problem:
During boot an external USB drive is not seen, causing an fsck error and dropping to a shell.

Version-Release number of selected component (if applicable):
udev-127-3.fc10.x86_64

How reproducible:
100% repeatable

Steps to Reproduce:
1.Boot system with external USB hard drive
2.Boot fails
3.Drop to shell, edit /etc/fstab and reboot, which works
  
Actual results:
Failed boot

Expected results:
Correct boot

Additional info:
The external drive is formatted as ext3 and identified as "Bus 002 Device 002: ID 059b:0275 Iomega Corp.". Following a suggestion on fedora-test-list, I tried setting udevtimeout=300 on the boot line, both in the grub.conf file and interactively. No effect (either to the boot time or to the error), so I suspect the drive is reporting it's ready when it isn't.
Comment 1 Harald Hoyer 2008-11-12 11:10:02 EST
what is wrong with udev?
Comment 2 Patrick O'Callaghan 2008-11-13 13:45:06 EST
(In reply to comment #1)
> what is wrong with udev?

I've no idea. I reported this under udev since I assumed udevsettle had something to do with udev.
Comment 3 Edgar Hoch 2008-11-17 18:09:45 EST
I have a similar problem with an external RAID with SCSI connection with Fedora 9 and the current packages (kernel-2.6.27.5-37.fc9.x86_64, udev-124-2.fc9.x86_64, initscripts-8.76.4-1.x86_64).

I also tried the boot option udevtimeout=300 and higher values, but no difference.
When I tried to also add udevtrace and udevdebug, then it works.

"Works" mean, that the partitions on the external RAID are available when they are needed by the mount command (that looks in /etc/fstab).
In the other case, not working, there are error messages that the block devices (or labels) for the filessystems cannot be found.

With udevtrace I saw, that udev recogniced them _after_ the prompt for the root password - that meens, that udev (?) has not wait until the SCSI bus was ready an registered all SCSI devices.

But udevtimeout with other values seems to change nothing.

Any idea?

Thanks in advance!
Comment 4 Patrick O'Callaghan 2008-11-17 21:41:48 EST
(In reply to comment #3)
> I have a similar problem with an external RAID with SCSI connection with Fedora
> 9 and the current packages (kernel-2.6.27.5-37.fc9.x86_64,
> udev-124-2.fc9.x86_64, initscripts-8.76.4-1.x86_64).
> 
> I also tried the boot option udevtimeout=300 and higher values, but no
> difference.
> When I tried to also add udevtrace and udevdebug, then it works.

I tried with udevdebug, but it made no difference in my case.
Comment 5 Bug Zapper 2008-11-26 00:14:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Harald Hoyer 2009-01-20 06:45:16 EST
is this still a problem?
Comment 7 Patrick O'Callaghan 2009-01-20 10:45:38 EST
Yes, no change. Running F10 with all updates.
Comment 8 Patrick O'Callaghan 2009-03-16 15:16:54 EDT
I just had to hard reboot because of a strange system hang and everything came up normally, i.e. it *appears* that the udevsettle problem went away. This is with kernel-2.6.27.19-170.2.35.fc10.x86_64 and udev-127-3.fc10.x86_64.

If it comes back I'll report again.
Comment 9 Patrick O'Callaghan 2009-03-17 00:25:14 EDT
Unfortunately it was a false alarm. The problem came back next time I rebooted (this time a soft boot). I've installed a temporary workaround by configuring "noauto" in the fstab entry and mounting the filesytem explicitly in /etc/rc.local. This seems to work.
Comment 10 Richard Monk 2009-07-21 23:23:03 EDT
I am having an identical issue.  F10 i386, fully updated.

Because the USB drive is relied on by the NFS, Samba, and Apache servers, I made a short init script to mount it before most other services start.

Is there any way to force udevsettle before doing the mounts?
Comment 11 Harald Hoyer 2009-07-22 08:08:30 EDT
you can wait for udev to be settled without a timeout.

udevadm settle
Comment 12 Patrick O'Callaghan 2009-07-22 10:33:16 EDT
That's good to know, however it's not of much practical value in my case. As stated above, I already disable noauto in /etc/fstab and mount the drive in /etc/rc.local. This works every time. To make use of "udevadm settle" I would have to do essentially the same thing, just add that line to /etc/rc.local. I suppose it wouldn't hurt to do it for safety, but it would be much better if the system itself did it automatically before trying to mount USB devices at boot time, in which case I could remove my hacked solution.
Comment 13 Bug Zapper 2009-11-18 03:50:26 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-12-18 01:49:38 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.