Bug 47122 - sadc reports "Invalid system activity file" without naming it
sadc reports "Invalid system activity file" without naming it
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: sysstat (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-03 07:47 EDT by Jonathan Kamens
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 22:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-07-03 07:47:22 EDT
Every time the sa1 cron job from sysstat runs on my machine, I get "Invalid
system activity file" in E-mail.  It doesn't say what file is invalid. 
Sadc needs to be fixed to print the file name in error messages.

(I'll address why I'm getting the error message in another bug report.)
Comment 1 Preston Brown 2001-08-13 15:57:37 EDT
4.0.1-2 will be more verbose about reporting these files.

What is the rest of your report, i.e. why things are broken in the first place?
Comment 2 Jonathan Kamens 2001-08-13 18:05:44 EDT
It appears that some time around the beginning of July, the file format of the
files in /var/log/sa changed.  I had old files with the old format, which is
what was causing the error.  Deleting all the files from /var/log/sa made the
error go away.

I suppose this needs to be release-noted and perhaps even worked around in the
sysstat postinstall script during upgrades.  Or perhaps the problem has been
fixed some other way since I encountered it at the beginning of July.
Comment 3 Preston Brown 2001-09-05 15:12:53 EDT
haven't seen this again, it will be a transient error anyway so I'm gonna let 
it slide.
Comment 4 Jonathan Kamens 2001-09-06 22:55:14 EDT
I do not agree with your decision to close this bug.  It is not
transient -- any time a system activity file gets corrupted, for
whatever reason, this bug will occur.  It's simply unacceptable for a
program to report that a file is corrupt without saying what the file
is.

If you insist on closing it, then please do so with the correct
resolution -- WONTFIX, not RAWHIDE.
Comment 5 Preston Brown 2001-09-07 12:41:38 EDT
sorry, you misinterpreted my response.  I did fix the bug where it doesn't tell
you what file was corrupted.  I didn't fix the bug of solving why the file was
corrupted.

Note You need to log in before you can comment on or make changes to this bug.