Bug 471221 - 1.5.3 server switching VTs via ALT-Fn instead of CTRL-ALT-Fn
1.5.3 server switching VTs via ALT-Fn instead of CTRL-ALT-Fn
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-11-12 09:43 EST by Thomas J. Baker
Modified: 2008-11-13 20:54 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.5.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 20:54:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (91.80 KB, text/plain)
2008-11-12 15:13 EST, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2008-11-12 09:43:24 EST
When I tried it last week from koji, at least on my intel based laptop, the VT switching was messed up. ALT-Fn would switch VTs and when you tried to switch back to VT1, the screen stayed black though you could see the cursor. I had to switch back to the 1.5.2 version.
Comment 1 Matěj Cepl 2008-11-12 12:08:15 EST
Are you sure you have upgraded system? It looks very much like duplicate of bug 467636, which was fixed ages ago.
Comment 2 Thomas J. Baker 2008-11-12 12:14:17 EST
I'm sure as I had to downgrade to get it fixed. I'll try the latest build again just to double check.
Comment 3 Thomas J. Baker 2008-11-12 15:13:43 EST
Created attachment 323386 [details]
Xorg.0.log
Comment 4 Thomas J. Baker 2008-11-12 15:14:57 EST
I just tried it again and it is just as I described. I don't have a xorg.conf.
I included the Xorg.0.log.old as I just had to reboot to recover.
Comment 5 Matěj Cepl 2008-11-12 21:36:20 EST
It is weird. Peter, it seems  bug 467636 was risen. It was risen indeed.
Comment 6 Peter Hutterer 2008-11-12 23:39:00 EST
The update to 1.5.3 resurrected it because the fix got lost during the upstream cherry-picking. Please try xorg-x11-server-1.5.3-3 available in koji now.

http://koji.fedoraproject.org/koji/taskinfo?taskID=930592
Comment 7 Thomas J. Baker 2008-11-13 08:47:19 EST
Seems to have fixed it. Thanks.
Comment 8 Jeremy Katz 2008-11-13 11:52:49 EST
Peter -- note that if you want newer builds tagged for Fedora 10 right now, you need to make a request to rel-eng (http://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy)

Currently...
[katzj@aglarond F-10]$ koji latest-pkg f10-final xorg-x11-server
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
xorg-x11-server-1.5.2-12.fc10             f10-final             ajax
Comment 9 Peter Hutterer 2008-11-13 20:54:53 EST
we'll leave 1.5.2-12 in for now, it doesn't suffer from the bug, and 1.5.3-1 never got tagged for F10 anyway.

Note You need to log in before you can comment on or make changes to this bug.