Bug 471236 - hts 5.3 tracebacking after plan
hts 5.3 tracebacking after plan
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
: 464784 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 11:00 EST by Rob Landry
Modified: 2014-03-25 20:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results.xml file from the tracebacking hts run (208.01 KB, text/xml)
2008-11-12 11:00 EST, Rob Landry
no flags Details
certificationtest.py patch to encode ascii so unicode strings are filtered (555 bytes, patch)
2008-11-12 14:10 EST, Greg Nichols
no flags Details | Diff
certificationtest.py patch to encode ascii so unicode strings are filtered (899 bytes, patch)
2008-11-12 22:22 EST, Greg Nichols
no flags Details | Diff

  None (edit)
Description Rob Landry 2008-11-12 11:00:02 EST
Created attachment 323337 [details]
results.xml file from the tracebacking hts run

Description of problem:

hts 5.3-1 is tracebacking after creating a plan.


How reproducible:

Every time.

Steps to Reproduce:
1. hts clean (answer yes to the questions)
2. hts plan (executes fine)
3. hts print (tracebacks)
  
Actual results:

[root@test1085 hts]# hts clean
filename is /etc/hts.xml
Error: hts is already running (lock file /var/lock/subsys/hts found)
Override? (y|n) y
response: y
/var/hts
Are you sure you want to delete all test results? (y|n) y
response: y
removing HTS logs ...
removing HTS results...
[root@test1085 hts]# hts plan
filename is /etc/hts.xml
/var/hts
filename is /etc/hts.xml
OS Version: Red Hat Enterprise Linux Client release 5.3 Beta (Tikanga)
Kernel RPM: kernel-2.6.18-122.el5
HTS version 5.3, release 1
Hardware: American Megatrends Inc. unknown X8DTN
OS: Tikanga 5.3
saved configuration to /var/hts/results.xml
Created a new plan with 26 tests on 150 devices
saved test plan to /var/hts/results.xml
[root@test1085 hts]# hts print
filename is /etc/hts.xml
/var/hts
filename is /var/hts/results.xml
Traceback (most recent call last):
  File "/usr/bin/hts", line 55, in ?
    success = hts.do(args)
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 162, in do
    result = self.doPrint()       
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 546, in doPrint
    self.load(silent=True)
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 198, in load
    self.certification.load(self.environment.getResultsPath())     
  File "/usr/share/hts/lib/hts/certificationtest.py", line 104, in load
    self.document = parse(file)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/minidom.py", line 1915, in parse
    return expatbuilder.parse(file)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line 930, in parse
    result = builder.parseFile(file)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line 207, in parseFile
    parser.Parse(buffer, 0)
xml.parsers.expat.ExpatError: reference to invalid character number: line 51, column 76
[root@test1085 hts]# 


Additional info:

the hts rpm doesn't seem to pass the verification check...

[root@test1085 hts]# rpm -V hts
S.5....T    /usr/share/hts/lib/hts/certificationtest.py
S.5....T    /usr/share/hts/lib/hts/certificationtest.pyc
Comment 1 Greg Nichols 2008-11-12 14:10:37 EST
Created attachment 323371 [details]
certificationtest.py patch to encode ascii so unicode strings are filtered


This patch changes hts so unicode strings are filtered for non-printing characters .
Comment 2 Greg Nichols 2008-11-12 22:22:09 EST
Created attachment 323418 [details]
certificationtest.py patch to encode ascii so unicode strings are filtered


this revised patch adds filtering to hal and kudzu logging
Comment 4 Greg Nichols 2008-11-21 10:48:45 EST
*** Bug 464784 has been marked as a duplicate of this bug. ***
Comment 6 Yan Tian 2009-01-01 23:59:49 EST
Verified it was fixed in hts-5.3-12.
Comment 8 errata-xmlrpc 2009-01-27 17:58:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.