Bug 471240 - CentOS servers cannot be easily registered after kickstarting
CentOS servers cannot be easily registered after kickstarting
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2008-11-12 11:14 EST by Justin Sherrill
Modified: 2009-09-10 08:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 08:04:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-11-12 11:14:13 EST
Since the CentOS distro does not include the needed registration client, It makes it hard to have a centOs machine registered after kickstarting.  

Currently we update certain packages in the %post, so for a centOS kickstart we could simply update/install all the needed packages in the %post section as well.  Should be fairly simple.
Comment 1 Stephen John Smoogen 2008-11-24 18:03:03 EST
Hmmm, would having such a client be useful in an extras repository? My limited understanding of why the client was not there was because it was not needed (eg you have yum and RHN was not OS. ) Would having a generic set of tools repository to register a client would be useful. And what src.rpm's would that need to be work with a spacewalk versus a RHN in particular?
Comment 2 Justin Sherrill 2009-03-18 11:40:15 EDT
BobFW1 trying to kickstart CentOs 5:	

BobFW1	jsherrill_laptop: I've tried to install the files manually
[11:26] 	BobFW1	there are four files missing from the list
[11:27] 	BobFW1	rhn-setup and its deps (rhnsd, rhn-check and rhn-client-tools)
[11:28] 	BobFW1	rhnreg_ks works after installing those
[11:28] 	jsherrill_laptop	BobFW1, so wget isn't pull those down ?
[11:29] 	BobFW1	no
[11:30] 	BobFW1	wget pulls: rhnlib pyOpenSSL and libxml2-python
[11:36] 	BobFW1	jsherrill_laptop: can the ks templates be edited manually?
[11:36] 	BobFW1	to fix the problem



So it looks like if we just have it install rhn-setup and its deps (rhnsd, rhn-check and rhn-client-tools), that might be all it needs to do...
Comment 4 Bob Huisman 2009-03-18 12:53:46 EDT
After some more attempts:

to get package installation working, the packages yum-rhn-plugin and
spacewalk-client-tools are also required.
Comment 5 Justin Sherrill 2009-03-18 16:47:25 EDT
spacewalk-client-tools shouldn't be required, but rhn-client-tools should (Spacewalk client tools is just a rpm with repo data and GPG keys for http://stahnma.fedorapeople.org/spacewalk-tools/).  But i will add yum-rhn-plugin.

Thanks Bob!
Comment 6 Bob Huisman 2009-03-19 10:31:47 EDT
Thanks. What I've seen now is that sometimes between the download of the kickstart and the download of the files (i mean rhnlib, pyOpenSSL and libxml2-python) the links have expired. 

The system will then download files, but instead of getting the files it gets the 'link expired or 404' page which it will try to install.

As a workaround: maybe it is an option to put the required files in the '/pub/' folder next to the RHN-SSL cert to make sure they are always available?
Comment 7 Justin Sherrill 2009-03-20 16:01:54 EDT
Have fixed this and centos will be auto registered by spacewalk


commit	f5376cb97e47c0a917b2234636013a5d96f99cfb
tree	7bd3654fa269c9a8cee19d07df4d495e05fa23d1	tree | snapshot
parent	10133e8951eb8ff61bdbac8b1d0ecb31cf08752a	commit | diff


Note, when upgrading from spacewalk 0.4 to 0.5 (when released) you need to delete the file located in /var/lib/rhn/kickstarts  that corresponds to your kickstart for it to be 'regenerated'.  Alternatively you can simply update the kickstart in the WebUi and it will be regenerated.
Comment 9 Miroslav Suchý 2009-09-10 08:04:59 EDT
Spacewalk 0.6 released

Note You need to log in before you can comment on or make changes to this bug.