Bug 471242 - error in post scriplet leaves system with 2 versions of httpd installed
error in post scriplet leaves system with 2 versions of httpd installed
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Joe Orton
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 11:17 EST by Don Vanco
Modified: 2012-05-10 11:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 11:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Vanco 2008-11-12 11:17:10 EST
Description of problem:
When using YUM to update I get an error relating to the post install scripts in httpd.  This appears to have resulted in a "corrupted" install that shows to versions of one package installed


Version-Release number of selected component (if applicable):
See steps below

How reproducible:
Have not tried, but assume it will not resolve magically

Steps to Reproduce:
1. have a system with httpd 2.2.3-11.el5_1.3 installed
2. use yum/rhn to update to httpd 2.2.3-11.el5_2.4
3. watch the error, verify with yum
  
Actual results:
Updating  : httpd                        ####################### [ 4/60]
service httpd does not support chkconfig
error: %post(httpd-2.2.3-11.el5_2.4.x86_64) scriptlet failed, exit status 1

[root@dvlap5 ~]# yum list httpd
Loading "rhnplugin" plugin
Loading "security" plugin
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00     
Installed Packages
httpd.x86_64                             2.2.3-11.el5_2.4       installed       
httpd.x86_64                             2.2.3-11.el5_1.3       installed  



Expected results:
A clean update that results in only one version of HTTPD installed

Additional info:
Whatever you need, just ask.
Comment 1 Joe Orton 2008-11-16 16:24:28 EST
Can you give the output of:

# rpm -V httpd chkconfig
# chkconfig --list httpd
Comment 2 Don Vanco 2008-11-16 21:44:33 EST
Joe, just you let you know, I ran an erase on the old package.
yum erase httpd-2.2.3-11.el5_1.3

Things still seem a bit wonky as you'll see below, so I suppose the best step would be to erase and reinstall (the current version).

...but here's the requested details:

[root@dvlap5 ~]# rpm -V httpd chkconfig
S.5....T c /etc/rc.d/init.d/httpd
missing     /usr/share/doc/httpd-2.2.3
missing   d /usr/share/doc/httpd-2.2.3/ABOUT_APACHE
missing   d /usr/share/doc/httpd-2.2.3/CHANGES
missing   d /usr/share/doc/httpd-2.2.3/LICENSE
missing   d /usr/share/doc/httpd-2.2.3/NOTICE
missing   d /usr/share/doc/httpd-2.2.3/README
missing   d /usr/share/doc/httpd-2.2.3/VERSIONING
missing   d /usr/share/doc/httpd-2.2.3/migration.css
missing   d /usr/share/doc/httpd-2.2.3/migration.html

[root@dvlap5 ~]# chkconfig --list httpd
service httpd does not support chkconfig

[root@dvlap5 ~]# head /etc/rc.d/init.d/httpd -n 15
#!/bin/bash
#
# httpd        Startup script for the Apache HTTP Server
#
# chkconfig: 85 15
# description: Apache is a World Wide Web server.  It is used to serve \
#              HTML files and CGI.
# processname: httpd
# config: /etc/httpd/conf/httpd.conf
# config: /etc/sysconfig/httpd
# pidfile: /var/run/httpd.pid

# Source function library.
. /etc/rc.d/init.d/functions



[root@dvlap5 ~]# ls -la /etc/rc.d/init.d/httpd
-rwxr-xr-x 1 root root 3198 Sep 25 11:12 /etc/rc.d/init.d/httpd
Comment 3 Joe Orton 2008-11-25 07:39:17 EST
Had you modified the init script in some way before performing the upgrade?  The -V output implies it is now modified:

S.5....T c /etc/rc.d/init.d/httpd

I can't see how the error from chkconfig could have occurred unless the init script had been modified or become corrupt somehow.
Comment 4 Don Vanco 2008-11-25 08:07:20 EST
I have not altered this (or any) init script on this host. I suppose corruption is possible, but I'd have to question from whence it came...

By any chance have you done a diff on the init script between the 2 versions?  My guess it's the script from the older, hence the validation output message.

I will have some free time in a couple days - if you like I can:
- revert to the old release by removing the current package, validating that the init script gets removed and then installing the old package
- run a verify to insure the script passes muster
- try the upgrade again
- verify the state of the script again

If there's any reason / benefit to using rpm -vs- yum (or vice-versa) just let me know
Comment 5 Joe Orton 2008-11-25 08:19:29 EST
No, there should be no change to the init script between those package versions.

It would certainly be useful to see if you can reproduce this.  I'd recommend specificially:

1) "yum erase httpd"
2) make sure the init script is removed from the filesystem
3) install the older release
4) rpm -V httpd
5) chkconfig --list httpd
6) "yum update httpd" to perform the upgrade
Comment 6 Joe Orton 2012-05-10 11:07:31 EDT
Since we lack a reliable reproduction case for this issue, this bug will be closed.

If you have issues impacting your use of Red Hat Enterprise Linux,
please contact your support representative.  Information about our production support process can be found at:  http://www.redhat.com/support/process/

Note You need to log in before you can comment on or make changes to this bug.