Bug 471259 - With latest testing updates, synergy uses all available cpu
With latest testing updates, synergy uses all available cpu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: synergy (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 12:34 EST by Orion Poplawski
Modified: 2009-03-09 19:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.3.1-12.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 18:45:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix so that infinite timeout (dtimeout < 0.0) is handled correctly (548 bytes, patch)
2009-02-22 20:27 EST, Peter Osterlund
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2008-11-12 12:34:49 EST
Description of problem:

I'm running with updates-testing enabled.  Last night I pulled in synergy-1.3.1-10.fc9, kernel-2.6.27.5-32.fc9.i686 and kde 4.1.3.  Now synergys consumes all available cpu.  strace shows:

[pid  6189] gettimeofday({1226510957, 98066}, NULL) = 0
[pid  6189] read(3, 0x8f1832c, 4096)    = -1 EAGAIN (Resource temporarily unavailable)                                                            
[pid  6189] gettimeofday({1226510957, 98217}, NULL) = 0
[pid  6189] read(3, 0x8f1832c, 4096)    = -1 EAGAIN (Resource temporarily^C <unfinished ..>                                             

Version-Release number of selected component (if applicable):
synergy-1.3.1-10.fc9.i386

How reproducible:
everytime
Comment 1 Jason Farrell 2008-11-13 15:04:47 EST
I can reproduce this.

1) on server: synergys
2) on client: "synergyc server"
3) reboot client after connected
4) notice synergys cpu usage is 100%  (sometimes you have to move the mouse around violently to see the cpu spike; sometimes not)
5) when client is booted back up, start "synergyc server" again
6) when it reconnects, synergys cpu usage goes back down
Comment 2 Matthias Saou 2009-01-02 11:06:26 EST
Does downgrading to 1.3.1-9 fix this particular issue?
Comment 3 Orion Poplawski 2009-01-16 18:32:21 EST
Yes.  FYI - I'm on F10 now and see the same (-10 sucks CPU, -9 doesn't).
Comment 4 Peter Osterlund 2009-02-22 20:27:51 EST
Created attachment 332889 [details]
Fix so that infinite timeout (dtimeout < 0.0) is handled correctly

I have the same problem with 100% CPU time in the server and my synergy client can't connect to the server. It looks like the stuttered-delay-fix patch didn't correctly handle the case when CXWindowsEventQueueBuffer::waitForEvent() is called with a negative value. The caller then appears to expect an infinite timeout, but instead got an immediate timeout with no calls to select()/poll(). The attached patch fixes this and makes it possible for me to use synergys on a fedora 10 system.
Comment 5 Matthias Saou 2009-02-26 10:40:55 EST
Thanks a lot for tracking the problem down and providing a patch! I'll test it and prepare updates-testing packages which include it.
Comment 6 Fedora Update System 2009-02-26 13:01:59 EST
synergy-1.3.1-12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/synergy-1.3.1-12.fc10
Comment 7 Fedora Update System 2009-02-26 13:02:08 EST
synergy-1.3.1-12.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/synergy-1.3.1-12.fc9
Comment 8 Fedora Update System 2009-02-27 22:22:33 EST
synergy-1.3.1-12.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update synergy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2159
Comment 9 Fedora Update System 2009-02-27 22:23:59 EST
synergy-1.3.1-12.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update synergy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2151
Comment 10 Stig Hackvan 2009-02-28 04:33:20 EST
i was having the same problem with synergy -10 and downgrading to -9 fixed it...  upgrading to -12 also seems fine, but -10 is absolutely screwed up so push the new version out into the world...
Comment 11 Gilboa Davara 2009-03-05 08:52:11 EST
I can confirm that -12 solves the problem.

Thanks!

- Gilboa
Comment 12 Fedora Update System 2009-03-09 18:45:24 EDT
synergy-1.3.1-12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-03-09 19:07:57 EDT
synergy-1.3.1-12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.