Bug 471261 - Computer hangs after resume. Probably Intel Gm45 related. Patch.
Computer hangs after resume. Probably Intel Gm45 related. Patch.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 12:45 EST by Tomasz Torcz
Modified: 2008-11-13 13:36 EST (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.27.5-101.fc10.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 13:36:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2008-11-12 12:45:09 EST
Description of problem:
On up to date rawhide on Thinkpad T400 (Intel Montevina/Cantiga X4500MHD graphics) I can't succesfully resume from either suspend or hibernation. Computer wakes up, but as soon as black X screen with cursor is displayed -- hangs.



How reproducible:
Always

Steps to Reproduce:
1. Hibernate or suspend.
2. Wake computer.
3. Wait until resume finish
  
Actual results:
Hang

Expected results:
Shouldn't hang, should return to desktop or ask for password to unlock screen.

Additional info:
This issue seems to be fixed by following patch:
http://lists.freedesktop.org/archives/intel-gfx/2008-November/000508.html
Comment 1 Tomasz Torcz 2008-11-13 13:36:35 EST
<airlied> zdzichuBG: yes -101 has it

Confirmed, resume works.
Thanks guys. In a month you fixed almost all bugs I've reported. Compared to my experience with Ubuntu (often >1 year of waiting for comment) you are incredibly awesome. Thank you!

Note You need to log in before you can comment on or make changes to this bug.