Bug 471320 - Unexpected behavior in NetworkManager
Unexpected behavior in NetworkManager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 17:55 EST by dan.weber
Modified: 2009-02-13 20:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 08:10:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dan.weber 2008-11-12 17:55:08 EST
Description of problem:
NetworkManager rendered unusable without dial-up packages installed

Version-Release number of selected component (if applicable):
0.7.0

How reproducible:
Uncheck Dial-up networking support in PackageKit and hit apply.

Actual results:
NetworkManager components removed for dependency and NetworkManager dies with error message about necessary files.

Expected results:
NetworkManager behaves normally. dial-up isn't an option.

Comments:
A very frustrating bug when you lose internet connectivity. Sure to drive away newcomers. Dial-up drivers should not be necessary on a machine that doesn't use dial-up.
Comment 1 Bug Zapper 2008-11-26 00:16:25 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Charles R. Anderson 2009-01-07 22:40:00 EST
You removed packages and didn't pay attention to what PackageKit was telling you it would remove?  I'm not sure what would be expected to fix here.
Comment 3 dan.weber 2009-01-08 18:32:56 EST
Yes, I wasn't really paying attention to what would be removed. I was simply doing my normal removal of all unwanted software after a fresh install (from live media) and I didn't thoroughly check the huge list of packages. Ideally, the dial-up module wouldn't be a necessary dependency. NM would automatically detect its presence (or absence) and act accordingly. My understanding is that this is how the current vpn module works. In this day and age, I would be surprised if more people used dial up than people use vpn.
Comment 4 Dan Williams 2009-02-13 08:10:02 EST
Dial-up (ie, PPP) is actually used for quite a few things: 3G/Mobile Broadband, PPPoE for Cable/DSL modems, and PPTP VPN support.  It's not really something that we can simply just remove at this time.

Part of the problem is that since it's necessary for some of these networking technologies, if you plug in a device that requires PPP, we can't really just pop up a dialog asking if you want to install PPP, because it's a good bet that you need network to get the PPP package but of course you don't have it yet...

Same sort of thing with wpa_supplicant; it's used for *wired* 802.1x too; and we can't really just remove it becuase it's pretty core to the networking system in many cases.
Comment 5 dan.weber 2009-02-13 20:40:21 EST
Thank you for the explanation.

Note You need to log in before you can comment on or make changes to this bug.