Bug 471351 - wacom drv causes SIGSEGV as xorg-server exits
wacom drv causes SIGSEGV as xorg-server exits
Status: CLOSED DUPLICATE of bug 468264
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 02:06 EST by Jeremy Huddleston
Modified: 2008-11-13 15:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 15:10:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Huddleston 2008-11-13 02:06:43 EST
Description of problem:

xorg-server crashes during shutdown when I have my wacom tablet connected.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e7746]
1: /usr/bin/Xorg(xf86SigHandler+0x39) [0x47d3a9]
2: /lib64/libc.so.6 [0x345f433100]
3: /usr/lib64/xorg/modules/input//wacom_drv.so [0x1072c45]
4: /usr/lib64/xorg/modules/input//wacom_drv.so [0x107bc55]
5: /usr/bin/Xorg(DeleteInputDeviceRequest+0x3b) [0x490e1b]
6: /usr/bin/Xorg(CloseDownDevices+0x29) [0x43fc29]
7: /usr/bin/Xorg(main+0x4ad) [0x42cd2d]
8: /lib64/libc.so.6(__libc_start_main+0xe6) [0x345f41e546]
9: /usr/bin/Xorg [0x42c0b9]

Fatal server error:
Caught signal 11.  Server aborting



Version-Release number of selected component (if applicable):

linuxwacom-0.8.0.3-4.fc10.x86_64

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-107.el5xen x86_64 
Current Operating System: Linux sephiroth.outersquare.org 2.6.27.5-94.fc10.x86_64 #1 SMP Mon Nov 10 15:19:36 EST 2008 x86_64
Build Date: 31 October 2008  01:39:18PM
Build ID: xorg-x11-server 1.5.2-12.fc10 


How reproducible:

100%

Steps to Reproduce:
1. telinit 3
2. X
3. ctrl-alt-backspace
  
Actual results:

SIGSEGV, stacktrace above

Expected results:

clean exit

Additional info:
Comment 1 Jeremy Huddleston 2008-11-13 02:10:33 EST
Bumping priority since this causes a SIGSEGV when the tablet is disconnected as well (just unplug it from USB).
Comment 2 Aristeu Rozanski 2008-11-13 15:10:56 EST

*** This bug has been marked as a duplicate of bug 468264 ***

Note You need to log in before you can comment on or make changes to this bug.