Bug 471392 - xorg fatals system when using PAE kernel
xorg fatals system when using PAE kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 08:49 EST by as
Modified: 2009-02-10 14:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 14:02:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log failed session (25.43 KB, text/plain)
2008-11-13 08:49 EST, as
no flags Details

  None (edit)
Description as 2008-11-13 08:49:32 EST
Created attachment 323448 [details]
Xorg log failed session

Description of problem:

When using a Fedora PAE kernel, I can only boot to text mode. If X is started, the system fatals (machine crashes, reboot!) in 5 out of 6 times. The 6th time, no fatal, but black screen and machine is hung.

Version-Release number of selected component (if applicable):
Started testing this with Fedora 10 snapshot 3, but also with all updates up until now (preview and later). No change in problem.

kernel-PAE-2.6.27.5-94.fc10.i686
xorg-x11-server-Xorg-1.5.2-12.fc10.i386
xorg-x11-drv-i810-2.5.0-3.fc10.i386
lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)


How reproducible:
Always

Steps to Reproduce:
1. Boot with most recent (or any other) i686 PAE kernel
2. X starts (but no mouse or anything seen yet)
3. Fatal
  
Actual results:
System crashes, reboot.

Expected results:
Should be same as non-PAE kernel: healthy system.


Additional info:
I figured out what's happening from the Xorg.0.log (attached) of the hung version (when the system fatals, no log gets written). See here:
---------------------------------------
(II) intel(0): Kernel reported 1264128 total, 1 used
(II) intel(0): I830CheckAvailableMemory: 5056508 kB available
---------------------------------------
I only have 4 GB installed in the system! Some sort of memory corruption?
So I tried the whole thing with the non-PAE kernel - and voila - everything works 100%. Except that I only have 3GB mem available now.
Comment 1 Bug Zapper 2008-11-26 00:18:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Adam Jackson 2009-02-10 14:02:57 EST
<@kylem> looks like before the has_gen thing on HIGHMEM64G got committed
<@kylem> should be able to close->currentrelease.

I believe my kernel maintainers.

Note You need to log in before you can comment on or make changes to this bug.