Bug 471411 - rpmdb panic
rpmdb panic
Status: CLOSED DUPLICATE of bug 468437
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-11-13 10:25 EST by Peter Robinson
Modified: 2008-11-13 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 17:06:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-11-13 10:25:40 EST
Put this under rpm and as a F10Target as I'm not sure whether it would be classed as a blocker and I think its more rpm than yum.

I'm getting a lot of yum/rpm crashes on latest rawhide (as on Nov 13th) on a x86_64 laptop. The root filesystem is running ext4 so I'm not sure if that is causing issues. If I then do a "rm -rf /var/lib/rpm/__db.00*" it seems to run just fine. I thought that issue was suppose to be fixed. I have had to do a couple of rpm --rebuilddb at times though.


[root@neo ~]# yum install pulseaudio-debuginfo speex-debuginfo libtheora-debuginfo libsoup-debuginfo
Loaded plugins: refresh-packagekit
rpmdb: page 2686: illegal page type or format
rpmdb: PANIC: Invalid argument
error: db4 error(-30975) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30975) from dbcursor->c_close: DB_RUNRECOVERY: Fatal error, run database recovery
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 84, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
    enabled_plugins=self.optparser._splitArg(opts.enableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 192, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 758, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 834, in _getsysver
    hdr = idx.next()
StopIteration
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30975) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30975) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30975) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30975) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery
[root@neo ~]#
Comment 1 Panu Matilainen 2008-11-13 17:06:24 EST
Having checked with other user with similar issues on F10, the pattern seems clear enough: rpmdb (Berkeley DB actually) is rather unhappy on ext4. Thanks for providing the necessary hint by mentioning ext4 being involved.

*** This bug has been marked as a duplicate of bug 468437 ***

Note You need to log in before you can comment on or make changes to this bug.