Bug 471421 - MATROX:G550 Fedora won't install using DVI monitor interface
MATROX:G550 Fedora won't install using DVI monitor interface
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
11
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
card_mgag550
:
: 495770 (view as bug list)
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2008-11-13 12:02 EST by Erik P. Olsen
Modified: 2010-06-28 06:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 06:48:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X.log (44.33 KB, text/plain)
2008-11-13 15:58 EST, Erik P. Olsen
no flags Details
My X.log from Fedora Preview-10 installation effort (71.71 KB, text/plain)
2008-11-14 12:16 EST, Martin A. Boegelund
no flags Details

  None (edit)
Description Erik P. Olsen 2008-11-13 12:02:20 EST
Description of problem:

I am using the DVI interface of Matrox Graphics Board MGA G550 with a Samsung SyncMaster 213T when building a Fedora 10 Beta system. 

When anaconda comes to the point where it switches to graphics mode black screen is displayed and nothing else happens. Running anaconda in text mode is OK and so is running it using the VGA interface.


Version-Release number of selected component (if applicable):

Fedora 10-Preview of Nov. 5


How reproducible:

Happens all the time.


Steps to Reproduce:
1.Insert Fedora 10-Preview DVD 
2.Connect the monitor to the DVI connector
3.boot DVD
  
Actual results:

Black screen


Expected results:

Anaconda wellcome screen


Additional info:
Comment 1 Chris Lumens 2008-11-13 14:39:05 EST
With the DVI connector attached, can you switch to tty2 and grab /tmp/X.log and attach it to this bug report?  Thanks.
Comment 2 Erik P. Olsen 2008-11-13 14:48:48 EST
(In reply to comment #1)
> With the DVI connector attached, can you switch to tty2 and grab /tmp/X.log and
> attach it to this bug report?  Thanks.

How do I switch to tty2?
Comment 3 Chris Lumens 2008-11-13 15:15:41 EST
ctrl-alt-f2
Comment 4 Erik P. Olsen 2008-11-13 15:58:07 EST
Created attachment 323499 [details]
X.log

X.log as requested.
Comment 5 Erik P. Olsen 2008-11-13 17:22:30 EST
Just to clarify: This is *not* the same as bug #466318 which dealt with the same graphics card but in analogue mode and has been duly fixed. This time the bug is with digital mode.
Comment 6 Martin A. Boegelund 2008-11-14 04:36:03 EST
I'm having trouble installing Fedora Preview-10 with a DVI monitor too. It simply doesn't work.
I've tried different resolutions as command line parameters: resolution=1280x960, but it still doesn't work - the resolution 1280x960 works on my current Fedora 9 installation, but I'm also experiencing trouble on my F9 - when I switch to any of the ttyX's, the screen is flashing, as if the Xserver is trying to start, but fails.

My video card is based on the ATI Radeon 9200 SE.
My monitor is an Acer AL2023WA.
Comment 7 Martin A. Boegelund 2008-11-14 12:16:33 EST
Created attachment 323606 [details]
My X.log from Fedora Preview-10 installation effort

Attached my X.log in order to provide more data for debugging.
Comment 8 Martin A. Boegelund 2008-11-16 15:04:07 EST
I have now tried Fedora 10 Desktop BETA CD, and Fedora 9 BETA installation CD. They both suffer from the same problem as described above with my Fedora 10 Preview DVD.

So I tried an Ubuntu 8.04 Desktop i386 live CD. Same problem.
I then tried the Ubuntu 8.04 CD in "Safe graphics mode" - and it works!

So it looks to me like it's possible for Linux to get into graphical mode of some kind with my DVI hardware setup.
Comment 9 Bug Zapper 2008-11-26 00:19:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Erik P. Olsen 2009-01-22 18:20:15 EST
Any progress so far with this bug?
Comment 11 Erik P. Olsen 2009-05-02 03:19:22 EDT
Ahem, we are rapidly approaching release of F11. Any chance the bug is fixed in F11?
Comment 12 Martin A. Boegelund 2009-05-03 10:44:22 EDT
I just tested F11-preview, and I can report that this bug remains in F11-preview.

Do we have to clone this to a separate bug report for F11-preview, or is it possible step up the version info for this one?
Comment 13 Adam Jackson 2009-05-08 14:04:56 EDT
Martin, your bug is unrelated; this is an mga bug, not a radeon bug.
Comment 14 Adam Jackson 2009-05-08 14:18:10 EDT
*** Bug 495770 has been marked as a duplicate of this bug. ***
Comment 15 Bug Zapper 2009-06-09 05:52:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Matěj Cepl 2009-11-05 13:20:35 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 17 Erik P. Olsen 2009-11-05 14:29:08 EST
Don't close it as INSUFFICIENT_DATA! Close IT as NO_INTEREST_IN_FIXING.
Comment 18 Matěj Cepl 2009-11-07 19:18:44 EST
I guess, it means you can reproduce it, right? :)

No, I won't close it until there is any interest in it.
Comment 19 Erik P. Olsen 2009-11-28 05:24:10 EST
Actually, I've given up waiting for a fix. A gave my good old Matrox G550 to a friend of mine running Windows.
Comment 20 Vedran Miletić 2009-11-28 07:49:12 EST
Erik, I'm sorry that it didn't get fixed. Unfortunately, open source simply doesn't work that way.

If you were a developer, you also would have no interest in hardware you don't own, or you don't get paid to work on. The problem here is that very few, if any, X developers use Matrox cards, and driver development itself isn't very active, as you can see:
http://cgit.freedesktop.org/xorg/driver/xf86-video-mga/log/

Fedora is just picking upstream changes here, and community patches. If there was someone in Fedora community interested in working on Matrox driver, it would get fixed.

A bit off topic, but that's exactly why KDE developers once said that KDE could survive a long time without it's users, but not a single day without it's developers.
Comment 21 Bug Zapper 2010-04-27 08:20:27 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Bug Zapper 2010-06-28 06:48:50 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.