Bug 471430 - Firefox fails to find custom configuration file
Firefox fails to find custom configuration file
Status: CLOSED DUPLICATE of bug 442406
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
http://support.mozilla.com/tiki-view_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 12:37 EST by Greg
Modified: 2008-11-15 20:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-15 20:12:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg 2008-11-13 12:37:35 EST
Description of problem:
Firefox provides a method of locking preferences via the "general.config.filename".  However Fedora's build of firefox fails to find the configuration file.  It will read the "general.config.filename" setting and is either looking in the wrong place for the config file or fails to read it altogether.

Version-Release number of selected component (if applicable):
This is with version 3.0.2-1

How reproducible:
ALWAYS

Steps to Reproduce:
1. touch /usr/lib64/firefox-3.0.2/defaults/preferences/loadcustom.js
echo "// tell firefox to load customized config file" >> /usr/lib64/firefox-3.0.2/defaults/preferences/loadcustom.js
echo "pref("general.config.obscure_value", 0);" >> /usr/lib64/firefox-3.0.2/defaults/preferences/loadcustom.js
echo "pref("general.config.filename", "mozilla.cfg");" >> /usr/lib64/firefox-3.0.2/defaults/preferences/loadcustom.js

2. touch /usr/lib64/firefox-3.0.2/mozilla.cfg
echo "// lock browser to auto-detect proxy settings" >> /usr/lib64/firefox-3.0.2/mozilla.cfg
echo "lockPref("network.proxy.type", 4);"

3. Start-up Firefox.  
  

Actual results:
You'll receive the following pop-up message
"Failed to read the configuration file. Please contact your system administrator."  click on OK and firefox closes.

Expected results:
Firefox should open to the user's configured start page.  *AND* Firefox should be configure to auto-detect proxy settings *AND* the user _can't_ change that setting.

Additional info:
I confirmed this is a bug with Fedora's build by trying the binary from mozilla.org

http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=43099

https://developer.mozilla.org/En/Automatic_Mozilla_Configurator:Locked_config_settings
Comment 1 Matěj Cepl 2008-11-15 20:12:39 EST

*** This bug has been marked as a duplicate of bug 442406 ***
Comment 2 Matěj Cepl 2008-11-15 20:15:13 EST
This closing of the bug means, that whatever happens will be in https://bugzilla.mozilla.org/show_bug.cgi?id=429141 not in our bugzilla.

Whole point is that with splitting between xurlrunner and firefox (which hasn't happened upstream), some files moved to the xulrunner directory from the firefox one.

Note You need to log in before you can comment on or make changes to this bug.