Bug 471434 - pidgin's gstreamer version dependency needs to be updated
pidgin's gstreamer version dependency needs to be updated
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pidgin (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Warren Togami
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 12:49 EST by Jeff Bastian
Modified: 2009-03-16 15:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-23 14:19:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2008-11-13 12:49:41 EST
Description of problem:
pidgin-2.5.1-3.el5 needs gstreamer-0.10.20-3.el5 to provide the symbol gst_registry_fork_set_enabled symbol

If you start with a RHEL 5.2 system and then upgrade just the pidgin and libpurple packages (and finch too if desired), then pidgin will fail to start and give an error:
  pidgin: symbol lookup error: pidgin: undefined symbol: gst_registry_fork_set_enabled

Upgrading to gstreamer from gstreamer-0.10.9-3.el5 to 0.10.20-3.el5 fixes the problem.


Version-Release number of selected component (if applicable):
libpurple-2.5.1-3.el5
pidgin-2.5.1-3.el5

How reproducible:
Every time

Steps to Reproduce:
1. Install a fresh RHEL 5.2 system
2. Upgrade the libpurple and pidgin packages to those from RHEL 5.3 Beta:
      finch-2.5.1-3.el5
      libpurple-2.5.1-3.el5
      libpurple-perl-2.5.1-3.el5
      libpurple-tcl-2.5.1-3.el5
      pidgin-2.5.1-3.el5
      pidgin-perl-2.5.1-3.el5
3. Run 'pidgin' from a terminal
  
Actual results:
pidgin: symbol lookup error: pidgin: undefined symbol: gst_registry_fork_set_enabled

Expected results:
pidgin should start running

Additional info:
Upgrading to gstreamer*0.10.20-3.el5 fixes the problem

The pidgin.spec file contains
  %if %{gstreamer_integration}
  BuildRequires:  gstreamer-devel >= 0.10
  %endif

This should probably be '>= 0.10.20'

It should probably also have a section
  %if %{gstreamer_integration}
  Requires: gstreamer >= 0.10.20
  %endif
Comment 1 Mark Doliner 2008-11-13 13:00:10 EST
FYI Pidgin only calls that function if it existed in the version of gstreamer that was installed at compile time.  For reference, here's the check in configure.ac:

AC_CHECK_LIB(gstreamer-0.10, gst_registry_fork_set_enabled,
   [ AC_DEFINE(GST_CAN_DISABLE_FORKING, [],
               [Define if gst_registry_fork_set_enabled exists])],
   [], [$GSTREAMER_LIBS])
Comment 3 Warren Togami 2008-11-23 14:19:02 EST
This is not a bug.  The customer upgraded to the RHEL-5.3 pidgin on their RHEL-5.2 system.

http://people.redhat.com/wtogami/temp/pidgin/
In any case, I bet these binaries will work.  A low priority security errata built against RHEL-5.2 will supercede the RHEL-5.3 beta version.  Please give these a test.

Note You need to log in before you can comment on or make changes to this bug.