Bug 471436 - FC10-preview Firefox crashed hard adding non-permanent security exception
FC10-preview Firefox crashed hard adding non-permanent security exception
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 13:08 EST by aepalea
Modified: 2008-12-21 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 18:38:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aepalea 2008-11-13 13:08:19 EST
Description of problem:


Version-Release number of selected component (if applicable):

Fresh network install of FC-10 preview, first boot after install.  


How reproducible:

Firefox crashed hard without saving any state, and I wasn't able to quickly find the same URL.  


Steps to Reproduce:
1. add an ssl security
2. click off "make exception permanent" (why is that the default, anyway?) 
3. click OK/done button 

Actual results:

FF completely vanished from the screen in about 1/20th of a second immediately after pressing the button.  So fast it made me blink.  
  
Expected results:

View of secure web page.  


Additional info:


Was looking for help getting my dual head to work properly.  I'll be filing another bug on that momentarily.  The https page that crashed me was some self-signed techno-geek howto concerning xrandr.  

I saw a couple of rendering glitches on my display while running FF very briefly (which never occurred under my well-aged FC6).  

One of the firefox rendering errors was a single line input text box rendering additional white background beyond the right edge of the window.  About 3cm of white rectangle flashed for 2/10th's of a second, then disappeared again.  

Possible, but I don't think likely, that this crash could have been a rendering glitch.  Have an ATI Sapphire RV370 X550, which did not initialize nicely during the installer (massive sparkle to the right of the mouse [on my left LCD screen, but not my mirrored CRT on the right] moving the mouse around, which went away after switching to a text console and back the graphic console).
Comment 1 Matěj Cepl 2008-11-13 16:29:39 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

Could you please also attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Christopher Aillon 2008-11-17 14:53:18 EST
Also, having the version numbers of firefox, xulrunner, and nss would be extremely useful.

rpm -q firefox xulrunner nss
Comment 3 Bug Zapper 2008-11-26 00:19:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 aepalea 2008-12-21 02:37:07 EST
I wish I could provide the info you requested.  Unfortunately, my FC10 experiment was short lived, about 24 hours.  

A while back I tried Hardy, problems with dual head and some outdated packages.  Then I tried again with FC10, various problems which I reported.  Then I tried again with Ibex and I got a usable system without much pain.  I don't have strong feelings either way.  Luck of the draw.  

The one thing I recall about the Ibex install is that when I went to activate dual head it put up a prompt window "you need to diddle some cryptic config file, would you like me to do that for you?"  Then my dual head worked.  Whatever it was that Ibex offered to do automatically is where I got stuck under FC10.  But there were various other things.  

Note that I didn't get any of the sparkle effects reported here during my Ibex experience, nor have I had the SSL cert crash reported here.
Comment 5 Matěj Cepl 2008-12-21 18:38:41 EST
Do I understand you correctly, that you are not likely to be interested in this issue on Fedora?

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.