Bug 471438 - Using HP 2133's power switch or soft switch (Fn+F2) to suspend/hibernate will cause double suspend/hibernate
Using HP 2133's power switch or soft switch (Fn+F2) to suspend/hibernate will...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 13:12 EST by Lebenskuenstler
Modified: 2009-12-18 01:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:50:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lebenskuenstler 2008-11-13 13:12:39 EST
Description of problem:


The may sound a little odd...
If you tell the HP 2133 to hibernate/suspend by using the power button or the hotkey Fn+F2 (and NOT just GNOME's switch off dialouge or right click on gnome-power-manager) the HP 2133 will suspend/hibernate correctly. But if you desire to wake it up you have to watch the HP 2133 resuming and the instant he reaches gdm/GNOME he will instantly go again into suspend mode. So you have to use the power switch again, then everything goes fine.

This came with some kernel update Fedora 10 I think, sorry I don't recall when exaclty. In F9 I don't recall such issue.
Comment 1 William Lovaton 2008-11-15 00:46:26 EST
I have exactly the same issue using rawhide with the latest updates on my Dell XPS M1210 laptop with nVidia graphics adapter using nv driver.

For me suspend have been working fine until some kernel update.  It still works fine but it has this little glitch that it goes back to suspend immediately after waking up from the first suspend.  Then I wake it up again and it works fine now.

Any idea on how to debug this?
Comment 2 Bug Zapper 2008-11-26 00:20:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 William Lovaton 2008-12-01 16:00:52 EST
Any idea why this is happening?

I now see that g-p-m "fails" to load after suspend because there is no icon in the tray area, there is just a blank space instead of the battery icon.  It then goes back to suspend.  resuming for the second time works fine and g-p-m show up correctly in the tray area.

Can anyone give me a clue on how to debug this?
Comment 4 Solomon Peachy 2008-12-17 11:56:33 EST
I'm also having this problem on my Acer Ferrari 4000 (x86_64) laptop with Fedora 10.  I use the suspend hotkey, and it suspends fine.  I hit a key to wake it up, the machine re-awakens briefly long enough to see a "suspending" message on-screen, and it suspends again.  hitting another key wakes it up fine.

This is a regression from Fedora 6,7,8,9, which worked fine.

I have this problem with both the 2.6.27.5-117 and 2.6.27.7-134 kernels.
Comment 5 Francois-Xavier 'FiX' KOWALSKI 2009-03-03 16:04:08 EST
Problem looking slightly the same, on an hp 8510w, running up-to-date fedora10/x86_64.

1. suspend ok (using either sleep button or gnome suspend)
2. at resume from suspend (power-button pressed), system hibernates
3. at resume from hibernation (power-button pressed), system hibernates again
4. at resume from hibernation (power-button pressed), system resumes ok

I have noting personal in /etc/acpi: just plain fedora10 things.

Any idea/patch?
Comment 6 Francois-Xavier 'FiX' KOWALSKI 2009-03-05 03:24:24 EST
I have a work-around for this problem that -- I think --demonstrate that this is indeed a gnome-power-manager bug.

The bug gives the impression that a single PM  events is interpreted several times, as if there were several registered actions for it:  for example old ones (from a previous user configuration, likely using a previous gnome-pm version) and new ones (saved by the new gnome-pm).

So I started gnome-pm & went through *all* settings, changing them one by one, hopefully to clean-up old settings from the gconf DB.

And that worked ;-)
Comment 7 Richard Hughes 2009-04-15 11:58:01 EDT
Does this still happen with the version in fedora rawhide, or the version of the Fedora 11 beta live cd?
Comment 8 Francois-Xavier 'FiX' KOWALSKI 2009-04-15 12:21:21 EDT
I cannot upgrade this individual component to f11-beta in my f10 without fully upgrading to f11-beta (at least all of the gnome parts).  I may have a look w/ f11-beta live cd.
Comment 9 Albert Bartoszko 2009-07-09 15:00:05 EDT
I'm having the some bug in F11 if module omnibook is used.
Unload it before suspend is a trick.
Comment 10 Richard Hughes 2009-08-20 07:34:22 EDT
This should be fixed already in F11 now.
Comment 11 Lebenskuenstler 2009-08-21 05:27:32 EDT
No, is not.
Comment 12 Bug Zapper 2009-11-18 03:51:23 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-12-18 01:50:33 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.