Bug 471442 - Rails fails to run due to rake version error
Rails fails to run due to rake version error
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-rails (Show other bugs)
el5
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael Stahnke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 13:30 EST by Joshua Baker-LePain
Modified: 2008-11-13 16:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 16:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Baker-LePain 2008-11-13 13:30:12 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.2) Gecko/2008092318 Fedora/3.0.2-1.fc9 Firefox/3.0.2

When I attempt to run the command 'rails', I get the following output:
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:578:in `report_activate_error': RubyGem version error: rake(0.7.3 not >= 0.8.1) (Gem::LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:134:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:158:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:157:in `each'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:157:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:49:in `gem'
        from /usr/bin/rails:15


Reproducible: Always

Steps to Reproduce:
1. yum install rubygem-rails
2. 'rails'
Comment 1 Joshua Baker-LePain 2008-11-13 14:05:36 EST
I just rpmbuilt the F8 src RPM for rubygem-rake-0.8.3-1 and rails seems happy now.  Is the rake version bump all that's needed?
Comment 2 Michael Stahnke 2008-11-13 15:19:47 EST
That's probably all that's needed.  I'll try to bump tonight.
Comment 3 Michael Stahnke 2008-11-13 16:49:16 EST
This is actually already built, it's just not in Stable.  Try the following.



yum --enablerepo='epel-testing' install rubygem-rake
Comment 4 Joshua Baker-LePain 2008-11-13 16:56:32 EST
Looks great -- thanks for the quick response!

Note You need to log in before you can comment on or make changes to this bug.