Bug 471462 - KDE Desktop gone after KDE update to 4.1.2
KDE Desktop gone after KDE update to 4.1.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 15:11 EST by alfonso
Modified: 2008-11-21 12:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 12:17:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Supposedly corrupted plasma-appletsrc (429 bytes, application/octet-stream)
2008-11-14 02:01 EST, alfonso
no flags Details
Supposedly corrupted plasmarc (14 bytes, application/octet-stream)
2008-11-14 02:01 EST, alfonso
no flags Details

  None (edit)
Description alfonso 2008-11-13 15:11:56 EST
Description of problem:
I have found an annoying problem after I updated my KDE version in fedora 9 to 4.1.2. A new kde-workspace version was detected by YUM and I applied the update. The dependencies were resolved and everything was Ok... until I exited the session and started a new one. The whole desktop is gone! No wallpaper, no panels, no context menus, no nothing... Just a grid of grey and white squares...

From a gnome session I have removed all kde files, and have installed the basic rpm packages from YUM. Still no success. The desktop is gone.

According to Krunner, plasma is up and running, as well as the other apps that are running in a normal KDEe session.

Version-Release number of selected component (if applicable):

kdebase-workspace-4.1.2-10.fc9.i386.rpm and libs (this was the package that apparently caused the problem).

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2008-11-13 15:21:00 EST
Somehow your Plasma configuration got corrupted. Try renaming (or deleting, but it's always good to have a backup) the .kde/share/config/plasma-appletsrc file in your home directory. Note that Plasma should not be running when you do this (because otherwise it'll write back a broken file), so best do it from your GNOME session.
Comment 2 Rex Dieter 2008-11-13 15:22:44 EST
Please attach your ~/.kde/share/config/plasmarc and ~/.kde/share/config/plasma-appletsrc files here for analysis.
Comment 3 alfonso 2008-11-14 02:01:09 EST
Created attachment 323541 [details]
Supposedly corrupted plasma-appletsrc
Comment 4 alfonso 2008-11-14 02:01:37 EST
Created attachment 323542 [details]
Supposedly corrupted plasmarc
Comment 5 alfonso 2008-11-14 02:03:44 EST
I have tried to remove both files several times when KDE is not running (its s the first recommendation found on the net), but the problem still persists. I have also tried to create a fresh new user and log in a KDE session for the first time. Still no success. The attached files are those created by KDE for the new user on the first login.
Comment 6 Jaroslav Reznik 2008-11-14 03:47:13 EST
Grey and white squares... Do you have composite mode turned on with KWin 4 (desktop effects)? With my ATI x700 and open source drivers it's messed up - many white/grey squares instead of windows/panels etc.
Comment 7 alfonso 2008-11-14 04:28:40 EST
I have tested it with composite mode turned on and off and still the same grey and white squares.
Comment 8 Rex Dieter 2008-11-14 08:25:00 EST
What Video card, driver is in use here?
Comment 9 alfonso 2008-11-14 09:20:17 EST
Video card is a nVidia GeForce 7300 SE
Driver installed is 173.14.12 from nVidia
Kernel is 2.6.26.6-79.fc9.i686

All kernel modules and drivers have been installed via YUM from the livna repository, and have been working just fine until the KDE workspace was updated.
Comment 10 Rex Dieter 2008-11-14 09:42:49 EST
We probably have to assume it's the nvidia driver to blame at this point.  (We've received several similar reports recently, especially when the Composite option is enabled in xorg.conf).

Unless, you can reproduce the problem using either nv or vesa driver.
Comment 11 alfonso 2008-11-14 12:06:33 EST
I have just removed the nVidia 173.14.12 driver and kernel modules, and have restarted the system using the nv module. The desktop is still gone. I have also given a  try to the vesa module and still the problems persists.
Comment 12 alfonso 2008-11-21 12:04:52 EST
Hi there!

Some news on this issue. I have just updated my box to kernel 2.6.27.5-41.fc9.i686 and the desktop is back. It is missconfigured, but at least is back.
Comment 13 alfonso 2008-11-21 12:05:40 EST
Sorry, I forgot to mention that the nVidia driver and kernel modules have also been updated.
Comment 14 Rex Dieter 2008-11-21 12:17:01 EST
OK, kernel/nvidia-driver issue it seems then.  thanks for the update.

Closing->NOTABUG (for lack of something better like, Closed->Nvidia joy)

Note You need to log in before you can comment on or make changes to this bug.