Bug 471464 - iwl3945 frequently causes kernel warnings
iwl3945 frequently causes kernel warnings
Status: CLOSED DUPLICATE of bug 470225
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 15:27 EST by Ben Gamari
Modified: 2008-11-14 09:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 09:27:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Gamari 2008-11-13 15:27:30 EST
Description of problem:
iwl3945 frequently causes kernel WARNINGs from its rate control code, causing a kerneloops notification.
Comment 1 Ben Gamari 2008-11-13 15:27:45 EST
------------[ cut here ]------------
WARNING: at include/../net/mac80211/rate.h:152 rs_get_rate+0x15a/0x88a [iwl3945]() (Not tainted)
Modules linked in: tun i915 drm rfcomm bridge stp bnep sco l2cap fuse sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath uinput snd_hda_intel snd_seq_dummy snd_seq_os
s snd_seq_midi_event snd_seq arc4 ecb crypto_blkcipher snd_seq_device iwl3945 snd_pcm_oss snd_mixer_oss rfkill snd_pcm mac80211 snd_timer i2c_i801 btusb snd_page_alloc dcdbas firewire_ohci snd_hwdep i2c_core snd firewire_core pcspkr yenta
_socket joydev rsrc_nonstatic bluetooth soundcore cfg80211 tg3 iTCO_wdt iTCO_vendor_support video libphy crc_itu_t output ac bay battery wmi [last unloaded: microcode]
Pid: 1508, comm: iwl3945 Not tainted 2.6.27.5-94.fc10.x86_64 #1

Call Trace:
 [<ffffffff810418f2>] warn_on_slowpath+0x60/0x90
 [<ffffffff8100e717>] ? __switch_to+0xb9/0x3e0
 [<ffffffff81166811>] ? __next_cpu+0x19/0x26
 [<ffffffff8103656c>] ? find_busiest_group+0x327/0x7d5
 [<ffffffff81166811>] ? __next_cpu+0x19/0x26
 [<ffffffff8103656c>] ? find_busiest_group+0x327/0x7d5
 [<ffffffffa0163cff>] rs_get_rate+0x15a/0x88a [iwl3945]
 [<ffffffff810597fa>] ? sched_clock_cpu+0x10f/0x120
 [<ffffffffa00f7045>] rate_control_get_rate+0x82/0xfc [mac80211]
 [<ffffffffa00fc064>] invoke_tx_handlers+0x33c/0xa8c [mac80211]
 [<ffffffffa00fb9ff>] ? __ieee80211_tx_prepare+0x2a2/0x2ef [mac80211]
 [<ffffffffa00fdb58>] ieee80211_master_start_xmit+0x226/0x3ba [mac80211]
 [<ffffffff8105a18b>] ? getnstimeofday+0x3a/0x96
 [<ffffffff812a61db>] dev_hard_start_xmit+0x1d6/0x258
 [<ffffffff812b7e7f>] __qdisc_run+0xed/0x206
 [<ffffffff812a44ba>] qdisc_run+0x36/0x3b
 [<ffffffff812a66ae>] dev_queue_xmit+0x344/0x453
 [<ffffffffa00f27a0>] ieee80211_sta_tx+0x6f/0x74 [mac80211]
 [<ffffffffa00f39ae>] ieee80211_send_auth+0x13e/0x14d [mac80211]
 [<ffffffffa00f658d>] ieee80211_sta_work+0x5c6/0x777 [mac80211]
 [<ffffffffa00f5fc7>] ? ieee80211_sta_work+0x0/0x777 [mac80211]
 [<ffffffff810518d9>] run_workqueue+0xa3/0x146
 [<ffffffff81051a71>] worker_thread+0xf5/0x109
 [<ffffffff81055199>] ? autoremove_wake_function+0x0/0x38
 [<ffffffff8105197c>] ? worker_thread+0x0/0x109
 [<ffffffff81054e53>] kthread+0x49/0x76
 [<ffffffff810116e9>] child_rip+0xa/0x11
 [<ffffffff81010a07>] ? restore_args+0x0/0x30
 [<ffffffff81054e0a>] ? kthread+0x0/0x76
 [<ffffffff810116df>] ? child_rip+0x0/0x11

---[ end trace 57a7c45086a29c2c ]---
Comment 2 John W. Linville 2008-11-14 09:27:19 EST

*** This bug has been marked as a duplicate of bug 470225 ***

Note You need to log in before you can comment on or make changes to this bug.