Bug 47147 - Crash at very end on testing X on textmode install
Summary: Crash at very end on testing X on textmode install
Status: CLOSED DUPLICATE of bug 47019
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-03 15:56 UTC by Telsa Gwynne
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-03 15:56:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Telsa Gwynne 2001-07-03 15:56:16 UTC
This might be a duplicate of bug 47019 because the symptoms are
exactly the same. But the traceback is different, so I'm opening
a new one and you can decide :)

Sony Vaio PCG-SR1K, NeoMagic chip with 3Mb video RAM, and 128Mb RAM.
Already established that graphical install died on attempting to start X.

Text mode install. Got all the way through to the X configuration section.
Corrected its assumption on the monitor (it thought a generic monitor but
it's LCD - already entered this one) and agreed with its assumptions for
X resolution: 16bit and 1024x768.

Told it not to start X on boot, agreed to test X. Bang. Traceback:

File "/usr/bin/anaconda", line 561, in ? intf.run(id, dispatch)
File "/usr/lib/anaconda/text.py", line 386, in run dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 120 in gotoNext self.moveStep()
File "/usr/lib/anaconda/dispatch.py" line 185, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 56, in writeKSConfiguration
id.writeKS(fn)
File "/usr/lib/anaconda/instdata.py", line 124, in writeKS
self.network.writeKS(f)
File "/usr/lib/anaconda/network.py", line 186, in writeKS
dev=self.netdevices[devNames[0]]
IndexError: list index out of range

There was a big "Debug" button. Hit it. Was dropped into pdb (python
debugger?) Guessed madly, typed 'help', then tried 'cont'. It said
"Install exited abnormally -- recieved [sic] signal 9"

(Yes, recieved, which is user-visible).

Then it started clearing up, told me that it was safe to reboot, I
did, expecting trouble, and it booted successfully into fairfax. Woo.
(Only caveat was that it booted to run-level 5, so I assume nothing from
the X setup was saved?)

Comment 1 Jeremy Katz 2001-07-04 01:30:58 UTC
Yep, duplicate of 47019; difference in traceback is due to difference between
text and gui install.  Also, typo of received is now fixed 

*** This bug has been marked as a duplicate of 47019 ***


Note You need to log in before you can comment on or make changes to this bug.