This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 471481 - check_ide_smart has incorrect ownership to work with NRPE
check_ide_smart has incorrect ownership to work with NRPE
Status: CLOSED DUPLICATE of bug 469530
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 16:40 EST by Ben Webb
Modified: 2009-01-11 10:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-11 10:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Webb 2008-11-13 16:40:20 EST
Description of problem:
As part of a recent update, the check_ide_smart plugin was changed to have root:nagios ownership, so that the Nagios daemon could run it. This made it break on our systems, however, where we run check_ide_smart on remote systems (not the main Nagios host) via the NRPE daemon (which runs as the nrpe user and nrpe group). In order for the plugin to now work on our systems, it must be manually changed to root:nrpe ownership (or made world-executable, I suppose).

Version-Release number of selected component (if applicable):
nagios-plugins-ide_smart-1.4.13-9.fc9.i386
nrpe-2.7-6.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Install the nagios-plugins-ide_smart package on a machine which has NRPE (*not* Nagios) installed.
2. Try to execute the plugin as the nrpe user (or alternatively, set up NRPE and then try to run a check_nrpe check of ide_smart from the main Nagios host):
% su nrpe -s /bin/sh -c /usr/lib/nagios/plugins/check_ide_smart 
  
Actual results:
Step (1) complains that the 'nagios' group does not exist (which is correct - it doesn't) and uses root instead to install the plugin. Step (2) reports 'permission denied'.

Expected results:
nrpe user can run the ide_smart check.

Additional info:
Comment 1 Jose Pedro Oliveira 2008-11-13 19:16:01 EST
This is a subset of bug 469530.
Comment 2 mail@romal.de 2009-01-11 10:40:30 EST
Yes Jose, you are right.

*** This bug has been marked as a duplicate of bug 469530 ***

Note You need to log in before you can comment on or make changes to this bug.