Bug 471496 - revert closed reason patch [NEEDINFO]
revert closed reason patch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 18:45 EST by Peter Robinson
Modified: 2013-03-05 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 02:42:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cwickert: needinfo? (davidz)


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-11-13 18:45:52 EST
The libnotify-closed-reason.patch breaks the libnotify api and has since been reverted upstream according to revision 3014, the change says "Prevent a backwards-compatibility breakage introduced where the "reason" code was added to the "closed" signal."

It was the cause of the ekiga crash in bug # 469132
Comment 1 Bug Zapper 2008-11-26 00:21:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Peter Robinson 2009-01-06 02:42:41 EST
This has now been dropped in rawhide and I've dropped the patch that was added to ekiga in Fedora 10 for the rawhide build so it didn't crash due to this patch. No idea what impact this will have on other packages.
Comment 3 Christoph Wickert 2009-02-15 06:27:39 EST
Any change we also get this into F10? It really sucks having to patch all apps that use libnotify for every new release they make.

The change was reverted upstream in http://trac.galago-project.org/changeset/3014 on September 26 2008 which was before F10 beta freeze, so I really think it should have been in F10 anyway.

Note You need to log in before you can comment on or make changes to this bug.