Bug 471504 - Bad X after transition from runlevel 3 to 5
Bad X after transition from runlevel 3 to 5
Status: CLOSED DUPLICATE of bug 471785
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 20:05 EST by Mads Kiilerich
Modified: 2014-03-16 23:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 09:41:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-11-13 20:05:48 EST
(21:16:29) kiilerix1: halfline: apropros tty magic, is it supported to boot to runlevel 3, login, and then telinit to 5?
(21:20:11) halfline: in that case it will but X on vt7
(21:20:41) kiilerix1: I'm quite sure that I saw something else ...
(21:20:58) kiilerix1: and X got in a state where I got a beep on most of the keypresses
(21:21:00) halfline: if it's not working file it
(21:21:24) halfline: ohhh so if you boot into runlevel 3
(21:21:28) halfline: that file will get written out
(21:21:36) kiilerix1: many strange things were going on, so I don't have an exact test case
(21:21:44) halfline: i think i know what's going on
(21:22:11) halfline: it's an artifact of the junky way we force the boot transition
(21:24:06) halfline: kiilerix1: if you add to /etc/event.d/quit-plymouth    the lines pre-start script \n rm -f /var/spool/gdm/force-display-on-active-vt \n end script right before the exec
(21:24:09) halfline: does your problem go away?
(21:26:47) kiilerix1: I will try next time I boot

(01:51:51) kiilerix: halfline: removing /var/spool/gdm/force-display-on-active-vt made it possible to make the transition from runlevel 3 to 5
(01:52:04) kiilerix: but doing it pre-start apparently didn't work
(01:52:34) kiilerix: doing it post-stop seemed to work
(01:52:42) kiilerix: when is the file created?
Comment 1 Bug Zapper 2008-11-26 00:21:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Mads Kiilerich 2008-12-03 09:23:21 EST
Hmm... Perhaps I saw it working.

Has it been fixed?
Comment 3 Ray Strode [halfline] 2008-12-03 09:41:12 EST
yup.

*** This bug has been marked as a duplicate of bug 471785 ***

Note You need to log in before you can comment on or make changes to this bug.