Bug 471516 - "Shuffle playlist" an new created empty playlist will generate CRITICAL error messages [NEEDINFO]
"Shuffle playlist" an new created empty playlist will generate CRITICAL error...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhythmbox (Show other bugs)
5.2
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 21:51 EST by Yolkfull Chow
Modified: 2014-06-02 09:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:21:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (yzhou)


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-11-13 21:51:27 EST
Description of problem:
New an empty playlist, right click on it and click "Shuffle playlist" will generate following error messages:

----------
(rhythmbox:6056): RhythmDB-CRITICAL **: rhythmdb_query_model_get_path: assertion `iter->stamp == model->priv->stamp' failed

(rhythmbox:6056): Gtk-CRITICAL **: gtk_tree_model_rows_reordered: assertion `new_order != NULL' failed
---------

Version-Release number of selected component (if applicable):
rhythmbox-0.11.6-4.el5

How reproducible:
Everytime

Steps to Reproduce:
1. launch rhythmbox, new an empty playlist
2. right click on the playlist and click "Shuffle playlist"
3.
  
Actual results:


Expected results:
When there is none songs in a playlist, if user "Shuffle playlist" the playlist, should be warned something like "No music in the playlist" instead of generate some CRITICAL error messages which may panic user.


Additional info:
Comment 2 RHEL Product and Program Management 2014-03-07 07:52:02 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:21:25 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.