This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 47156 - system freeze on VIA/IDE + SAMSUNG hd
system freeze on VIA/IDE + SAMSUNG hd
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-03 13:04 EDT by Gerald Teschl
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 08:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-07-03 13:04:34 EDT
About every 30-60 minutes my system will suddenly freeze for a few seconds
and then resume while spitting out the messages
-----------
hda: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hda: status timeout: status=0xd0 { Busy }
hda: drive not ready for command
ide0: reset: success
----------
During the time the entire system is frozen (including mouse) and the
harddisk led will light continuously even though I can hear no harddisc
activity.
Sometimes the system will not return to normal (I wated for a few minites)
at all and
I have to pull the plug. This is a fresh install with the latest errata
kernel
(2.4.3-12) plus all updates.

I have only one ide drive (primary master). I have tried to disable dma for
this drive and turned off the second ide bus in the bios. But to no avail.

Moreover, this is a dual boot machine RH7.1/Win2000 and the problem is not
present under Windows, so it is not a hard ware defect.

Some hardawre information:
----------------------------------------
VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt82c596a (rev 05) IDE UDMA33 controller on pci00:07.1
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
hda: SAMSUNG SV0844D, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
--------------------------
[root@tomcat /proc]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT82C691 [Apollo PRO] (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo
MVP3/Pro133x AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev
05)
00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management
00:09.0 SCSI storage controller: Adaptec AIC-7881U
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
00:0b.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 11)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC AGP
(rev 7a)
Comment 1 Arjan van de Ven 2001-07-03 13:08:12 EDT
Could you try passing "ide=nodma" as kernel option on the lilo prompt?
That makes Linux avoid DMA on the drive
Comment 2 Gerald Teschl 2001-08-06 16:13:59 EDT
I tried to turn dma off in /etc/sysconfig/harddiscs but that seems to
get ignored!?

Anyway, turning off dma does not help. It looks like there is some conflict with
my second network card an ne2k-pci model.
Comment 3 Gerald Teschl 2001-08-08 08:05:27 EDT
It is a problem with the hard drive only. I just put the hd into an entirely

differnent box and the problem persists. I also tired kernel-2.4.7-0.3.

Comment 4 Gerald Teschl 2001-09-13 12:36:07 EDT
I replaced the hd by a different one. Probalby not worth further pursuing this
bug.

Note You need to log in before you can comment on or make changes to this bug.