Bug 471600 - Renewing DHCP lease sometimes brings down vpnc connection
Renewing DHCP lease sometimes brings down vpnc connection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 10:45 EST by Pekka Savola
Modified: 2008-12-01 12:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 12:14:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Longer log, also showing a period later when it was working OK. (9.38 KB, text/plain)
2008-11-14 10:45 EST, Pekka Savola
no flags Details

  None (edit)
Description Pekka Savola 2008-11-14 10:45:09 EST
Created attachment 323591 [details]
Longer log, also showing a period later when it was working OK.

Description of problem:
Renewring DHCP lease sometimes seems to bring down vpnc connection


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.11.svn4022.4.fc9
Networkmanager-vpnc-0.7.0-0.10.svn4024.fc9

How reproducible:
Have WLAN connection managed by Network Manager.  Enable vpnc from NM applet.
After some time (in this case, a couple of minutes) the VPN session goes down.  Selecting disconnect and reconnect from NM applet brings the VPN session back up.

Additional info:

When vpnc stopped working with 'ip route list' the default routes again pointed through wlan0, not tun0.

Relevant parts of syslog:

Nov 14 10:05:56 lapps NetworkManager: <info>  VPN plugin state changed: 4
Nov 14 10:05:57 lapps ntpd[2301]: Listening on interface #8 tun0, 193.166.16.139#123 Enabled
Nov 14 10:06:33 lapps dhclient: DHCPREQUEST on wlan0 to 193.166.6.126 port 67
Nov 14 10:06:33 lapps dhclient: DHCPACK from 193.166.6.126
Nov 14 10:06:33 lapps NetworkManager: <info>  DHCP: device wlan0 state changed bound -> renew
Nov 14 10:06:33 lapps NetworkManager: <info>    address 193.166.6.77
Nov 14 10:06:33 lapps NetworkManager: <info>    prefix 25 (255.255.255.128)
Nov 14 10:06:33 lapps NetworkManager: <info>    gateway 193.166.6.126
Nov 14 10:06:33 lapps NetworkManager: <info>    nameserver '193.166.4.25'
Nov 14 10:06:33 lapps NetworkManager: <info>    nameserver '193.166.0.249'
Nov 14 10:06:33 lapps NetworkManager: <info>    domain name 'csc.fi'
Nov 14 10:06:33 lapps dhclient: bound to 193.166.6.77 -- renewal in 260 seconds.
Nov 14 10:06:34 lapps NetworkManager: <info>  Policy set (wlan0) as default device for routing and DNS.

More logs attached.
Comment 1 Pekka Savola 2008-12-01 07:19:36 EST
This appears to be fixed since 0.7.0-0.12.svn4295, there is a changelog entry:

"- DHCP renewal sometimes breaks VPN (rh #471852)", bu that PR reference is probably wrong because there doesn't seem to be relation to that bug #, rather than this one.
Comment 2 Pekka Savola 2008-12-01 07:20:32 EST
And another, even closer one: "- Fix mangling of VPN's default route on DHCP renew" without bug# reference (should be this one I guess).
Comment 3 Dan Williams 2008-12-01 12:14:34 EST
Yeah, it was supposed to be this one.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.