Bug 471644 - Missing a dependency of Condor
Missing a dependency of Condor
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: condor (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Farrellee
Fedora Extras Quality Assurance
http://kezhong.wordpress.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 14:49 EST by Kezhong Liang
Modified: 2008-11-15 20:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-15 20:58:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Resolution methods (9.19 KB, application/vnd.oasis.opendocument.text)
2008-11-14 14:49 EST, Kezhong Liang
no flags Details

  None (edit)
Description Kezhong Liang 2008-11-14 14:49:53 EST
Created attachment 323635 [details]
Resolution methods

Description of problem:
When I configure the Condor, it reminds me of lacking 2 directories(sql,man).

Version-Release number of selected component (if applicable):
Condor-7.0.5

How reproducible:


Steps to Reproduce:
1./usr/sbin/condor_configure --install
2.
3.
  
Actual results:
# Missing release directories (looking in /usr):
#  sql
#  man
# Unable to find some release directories. 

#cp: cannot stat `/usr/etc/examples/condor_config.generic': No such file or directory

Expected results:


Additional info:
I manually installed the planner package, then I can find these two directories. I need to symbolic link them to the release directories. I think you didn't consider the dependency of the planner package.
Comment 1 Matthew Farrellee 2008-11-15 20:58:07 EST
I would not recommend using condor_configure, specifically in the case of performing an installation. By installing the condor package you have already installed condor, no need to use condor_configure, which expects a specific directory structure produced only after compiling condor.

If you are looking to reconfigure condor, you should look in ~condor/condor_config.local. There is little benefit to using condor_configure for reconfiguration.

As for the dependencies, the planner package probably just happens to have a directory in the right place, there is no real dependency.

BTW, where you run condor_configure from is very important, because of how it operates. The where is not clear from your steps to reproduce.

FYI, I posted this information as a comment on your blog a day or two ago, comment is still waiting moderator approval.

I'm going to close this as NOTABUG.

Still glad you are getting familiar with Condor.

Note You need to log in before you can comment on or make changes to this bug.