Bug 471658 - anaconda loader should not bring up network if ks=hd:
anaconda loader should not bring up network if ks=hd:
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-11-14 16:18 EST by Warren Togami
Modified: 2009-02-16 15:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vnc-and-non_remote_ks.patch (2.58 KB, patch)
2008-11-14 19:56 EST, David Cantrell
no flags Details | Diff
0001-Do-not-bring-up-network-for-non-remote-kickstart-loc.patch (3.22 KB, patch)
2008-11-17 15:52 EST, David Cantrell
no flags Details | Diff

  None (edit)
Description Warren Togami 2008-11-14 16:18:35 EST
preupgrade wrote something like this into /boot/grub/grub.conf:

title Upgrade to Rawhide
        kernel /upgrade/vmlinuz preupgrade repo=hd:UUID=b9215874-6e70-4fc9-846b-a7d3c18d2572:/var/cache/yum/preupgrade stage2=hd:UUID=d74b467d-5b0b-47e3-beac-b883ccd7bf74:/upgrade/install.img ks=hd:UUID=d74b467d-5b0b-47e3-beac-b883ccd7bf74:/upgrade/ks.cfg
        initrd /upgrade/initrd.img

anaconda during the loader demands that I choose an interface to bring up, either eth0 or wlan0, despite anaconda not needing networking.  So perhaps it shouldn't ask to choose an interface if ks=hd:?

preupgrade could still require networking if there was insufficient space to write /boot/upgrade/install.img.  It would have stage2=http:// instead of stage2=hd:  So make sure this and other legitimate cases where it needs networking do not break.
Comment 1 Will Woods 2008-11-14 17:41:43 EST
I assume that the upgrade would proceed as normal if you configured the interface anyway? Not really a blocker, if that's the case.
Comment 2 David Cantrell 2008-11-14 18:14:32 EST
I'm working on a patch right now.  It's not a blocker, from my point of view.  Like Will said, the installation will proceed once the interface is up, the user may just be left wondering why they had to configure the interface.

If the patch is simple, I'll consider it for F-10.  I'll post here once I have more to report.

Thanks.
Comment 3 David Cantrell 2008-11-14 19:56:55 EST
Created attachment 323673 [details]
vnc-and-non_remote_ks.patch

I think this will fix the issue.  Remove the redundant call to kickstartNetworkUp() in loader.  If the user specifies vnc, that requires loader to configure networking because we can't present the network configuration UI until we have a display (catch 22 with vnc).  So, if they specify vnc *and* the kickstart parameter is a non-network source, set the LOADER_FLAGS_EARLY_NETWORKING flag, which is what I did for the syslog= parameter to make sure we bring up networking in loader.

Chris, can you comment?
Comment 4 Chris Lumens 2008-11-17 15:45:36 EST
I made a couple comments elsewhere that I'll sum up here for completness.  (1) The test in the first hunk for !strncmp(ksFile, "ks=", 3) will throw out the possibility of it just being "ks" which can happen under the NFS case.  (2) Don't we want to break the tie between VNC and network case, and then change it to be isKickstartFileRemote(loaderData->ksFile) instead?

With those modifications, it looks good to go ahead and commit.
Comment 5 David Cantrell 2008-11-17 15:52:23 EST
Created attachment 323796 [details]
0001-Do-not-bring-up-network-for-non-remote-kickstart-loc.patch

Updated patch.  Sending to the devel list for review.
Comment 6 David Cantrell 2008-11-17 17:12:14 EST
Patch in anaconda-11.4.1.59-1.
Comment 7 Bug Zapper 2008-11-26 00:24:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.