Bug 471666 - Fresh install brings in glibc-devel.i386 on x86_64 system.
Fresh install brings in glibc-devel.i386 on x86_64 system.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 17:00 EST by Orion Poplawski
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 05:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-11-14 17:00:09 EST
Description of problem:

Fresh install on x86_64.  gcc errors with:

In file included from /usr/include/features.h:359,
                 from /usr/include/stdio.h:28,
                 from /usr/include/plplot/plplot.h:67,
                 from temp.c:1:
/usr/include/gnu/stubs.h:9:27: error: gnu/stubs-64.h: No such file or directory

# rpm -q glibc-devel
glibc-devel-2.8.90-16.i386

Version-Release number of selected component (if applicable):
gcc-4.3.2-7.x86_64

How reproducible:
Several times now...
Comment 1 Jakub Jelinek 2008-11-14 17:07:37 EST
That would be an anaconda or yum bug.
Comment 2 Bug Zapper 2008-11-26 00:24:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 seth vidal 2008-12-10 09:41:02 EST
This is a brand new install from anaconda w/o any yum update or yum install command run on it?
Comment 4 Orion Poplawski 2009-02-16 11:49:40 EST
Yup.  At install, glibc-devel.i386 is installed:

[root@berretto ~]# grep glibc install.log
Installing glibc-2.9-2.i686
Installing glibc-2.9-2.x86_64
Installing glibc-common-2.9-2.x86_64
Installing glibc-headers-2.9-2.x86_64
Installing glibc-devel-2.9-2.i386
Comment 5 seth vidal 2009-03-06 16:28:28 EST
I can't find any replicators of this.

Can you try it out on a rawhide  or f11alpha install and see if it is still the case?
Comment 6 Orion Poplawski 2009-03-10 11:49:12 EDT
Okay, I think I know what's triggering the issue.  I have:

glibc-devel.i386

in my kickstart file because I need it for Intel Fortran support.  But I still think gcc.x86_64 should bring in glibc-devel.x86_64 since it can't build anything without it.  Current discussion on fedora-devel suggests:

Requires: glibc-devel%{__isa}
Comment 7 Orion Poplawski 2009-03-10 11:51:37 EDT
Oops just one underscore:

Requires: glibc-devel%{_isa}
Comment 8 Jakub Jelinek 2009-08-03 05:21:47 EDT
That's incorrect.  gcc can of course build stuff even with just glibc-devel.i[56]86 installed.  Of course just 32-bit, not 64-bit.

Note You need to log in before you can comment on or make changes to this bug.