Bug 471674 - console-kit-deamon spawns too many threads
console-kit-deamon spawns too many threads
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
https://bugs.freedesktop.org/show_bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 17:44 EST by Linus Walleij
Modified: 2014-03-16 23:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 22:44:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 17720 None None None Never

  None (edit)
Description Linus Walleij 2008-11-14 17:44:59 EST
Description of problem:
console-kit-deamon spawns too many threads
it should spawn one for each console, but it spawns 64 threads. Way too much.

Version-Release number of selected component (if applicable):
current

How reproducible:
always

Steps to Reproduce:
ps -eLf|grep console-kit-daemon|wc -l
  
Actual results:
64

Expected results:
find /sys/class/vc/ | grep vcs | wc -l
= 16

Additional info:
Upstream bug:
https://bugs.freedesktop.org/show_bug.cgi?id=17720
Proposed patch from Ubuntu forum:
http://launchpadlibrarian.net/15940846/0001-Autoconfigure-maximum-number-of-kernel-consoles.patch
Comment 1 Bug Zapper 2008-11-26 00:24:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Admin XMLRPC Client 2009-04-08 13:00:33 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Linus Walleij 2009-04-08 16:14:27 EDT
Move back to rawhide, where it's to be fixed.
See upstream bug at freedesktop.org for details of the fix.
Comment 4 Bug Zapper 2009-06-09 05:52:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 jmccann 2009-09-23 22:44:16 EDT
We'll track this issue upstream.
Comment 7 Linus Walleij 2009-09-25 15:03:19 EDT
Kudos to Lennart for digging upp the root cause and fixing this
the proper way! Thanks.

Note You need to log in before you can comment on or make changes to this bug.