Bug 471732 - Explicit uid 39 requested by Canna even Canna user is NOT listed within uidgid setup file
Explicit uid 39 requested by Canna even Canna user is NOT listed within uidgi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Canna (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 04:55 EST by Ondrej Vasik
Modified: 2008-11-17 13:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-16 21:11:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Vasik 2008-11-15 04:55:08 EST
Description of problem:
Canna claims explicit uid 39 without listing Canna user within oficial uidgid file. This could cause troubles when uid 39 is already in use on the system. Is there any need for that explicit uid 39? If so, it should have been requested to be added into uidgid file in setup package(no such requested filled in bugzilla so far).

How reproducible:
Always

Steps to Reproduce:
1. See /usr/share/doc/setup-*/uidgid
  
Actual results:
No Canna user within uidgid file

Expected results:
Canna user within uidgid file OR Canna user WITHOUT explicit uid request.

Additional info:
Just for your info, I'm setup package maintainer and there is very few number of uid/gids left under 100. Recently was requested to add audio and video group to Fedora, I have chosen two gid numbers - and one of those was 39 ... so without my initiative and google search for possible usage of this uid/gid it would have been taken without any warning and canna will be no longer running correctly. Please let me know if this explicit requirement is really needed (and canna user should be added to uidgid file - or if that uidgid number could be used (and explicit number uid 39 could be removed from canna))
Comment 1 Akira TAGOH 2008-11-16 21:11:21 EST
That issue has been fixed since FC-6. it no longer requests the explicit uid/gid.
Comment 2 Ondrej Vasik 2008-11-17 13:37:26 EST
Ah, sorry, my fault, it seems I accidently looked to very old spec file when browsing web. So will use that uidgid pair in rawhide , thanks for quick response.

Note You need to log in before you can comment on or make changes to this bug.