Bug 471733 - Can't make appleboot partitionon very large drives on G3 iBook
Can't make appleboot partitionon very large drives on G3 iBook
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 05:24 EST by Joel Rees
Modified: 2008-11-26 13:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 13:14:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Rees 2008-11-15 05:24:14 EST
Description of problem:
When trying to install Fedora 9 on a clamshell iBook G3 with a very large hard (160GB) disk drive, the installer fails to make the 1MB appleboot partition and thus the install fails.


Version-Release number of selected component (if applicable):
I'm not sure where to find the version number, it was the release version of F9 from before the flap about the keys.

How reproducible:
Every time on the clamshell G3 with 160 GB hard disk. 

Tried every workaround path I could think of, letting the installer completely wipe the disk and install on the default layout, setting up my own preferred partition map by hand, even tried pre-formatting with the Mac OS 9 formatting tool.

With the same 160 GB hard disk on a white iBook G4, there were no problems. Also, with a 30GB hard disk on the clamshell iBook G3, partitioning the appleboot partition succeeded and install proceeded far enough I could log in to a text console.

The 160 GB drive is now in service in the G4, so I won't be able to test any further, barring drastic changes in my time and financial budgets.

Steps to Reproduce:
See comments under "How reproducible".
  
Actual results:
No Appleboot partition, installer fails to proceed.

Expected results:
An Appleboot partition, or the installer proceeds and allows booting through openfirmware.

Additional info:
Related bug: 460390 (Filing separate bug under instruction from Joel Granados.)

For what it's worth, I would be happy with a boot procedure similar to openbsd, if the installer could be persuaded to proceed without building an Appleboot partition. 

In fact, on the G3 in question, I would prefer not to waste a boot firmware level partition on the Appleboot partition. The boot rom for the clamshell only allows 16 partitions before it refuses to boot, and I would like to multi-boot Mac OS 9, Mac OS X, Fedora, and openBSD on it.

One more point, Mac OS 9 and Mac OS X 10.2 apparently only recognize 120G of the disk.
Comment 1 Chris Lumens 2008-11-16 22:41:22 EST
Please attach the error message you are getting at this point to the bug report so we can see how it's failing.  Thanks.
Comment 2 Joel Rees 2008-11-21 06:50:09 EST
I have to apologize for not being very quick to respond.

I also have to apologize for not taking the right notes when I hit this. Bug #460390, as I noted, has the best information I can give on it. I spent a couple of days swagging, and I just don't remember what all I tried and what all the results were.

I'd love to have had the time, physical workspace, and money to spare on keeping the machine configuration available for further OS work, but I needed the drive in the G4 iBook.

I may get a chance to buy a large notebook drive for backup in a couple of months. If I do, and if I can spare the time to break the clamshell back down, I'll try again then before I put the drive in a USB/firewire shell and start using it for backup. But that's a maybe, and it is not now.

Again, my apologies.
Comment 3 Bug Zapper 2008-11-26 00:26:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Andy Lindeberg 2008-11-26 13:14:50 EST
We've never seen this, so please reopen if you run into it with F10.

Note You need to log in before you can comment on or make changes to this bug.