Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 471736 - ERROR with rpm_check_debug vs depsolve:
ERROR with rpm_check_debug vs depsolve:
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 06:27 EST by David Woodhouse
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-15 12:45:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum debug output (136.41 KB, text/plain)
2008-11-15 06:27 EST, David Woodhouse
no flags Details
list of installed packages. (43.32 KB, text/plain)
2008-11-15 06:29 EST, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2008-11-15 06:27:49 EST
Created attachment 323689 [details]
yum debug output

Upon upgrading from F8 to F9 wuth yum, I started seeing strange errors when I would 'yum update' with the 'fedora' repo (or my local mirror of it) included:

Setting up Update Process
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 104, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 339, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 195, in doCommand
    return base.updatePkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 561, in updatePkgs
    self.update()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 2490, in update
    updated_pkg = self.rpmdb.searchPkgTuple(old)[0]
IndexError: list index out of range

Updating individual packages seemed to work though, even with the full repo enabled. So I did a few manually, and then got this error:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
xorg-x11-drv-magictouch is needed by (installed) xorg-x11-drivers-7.2-9.fc8.i386
Complete!
(1, [u'Please report this error in bugzilla'])
Comment 1 David Woodhouse 2008-11-15 06:29:24 EST
Created attachment 323690 [details]
list of installed packages.

As I said, I was trying to upgrade from F8 to F9. 

[root@baythorne ~]# grep fc8 installed-rpms  | wc -l
887
[root@baythorne ~]# grep fc9 installed-rpms | wc -l
237

But it did explictly _ask_ me to file the bug in bugzilla... and this kind of upgrade normally works without problems (except dependency stuff in the packages themselves).
Comment 2 James Antill 2008-11-15 10:27:07 EST
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 2490, in update
>     updated_pkg = self.rpmdb.searchPkgTuple(old)[0]
> IndexError: list index out of range

...weird ... I assume this part still happens? Do you feel like putting a print "DBG:", old in there?
 What version of yum are you using (--version output)?
 Can you update to the yum version in rawhide?
 Also the debug output uses "-v -v -v" this isn't cumlative, you want just "-d 9" ... also can you upload the "-d 9" output for the simple "yum update" without any args.

> ERROR with rpm_check_debug vs depsolve:
> xorg-x11-drv-magictouch is needed by (installed)
> xorg-x11-drivers-7.2-9.fc8.i386

 Does "package-cleanup --problems" show anything? Does yum-complete-transaction do anything?
Comment 3 David Woodhouse 2008-11-15 11:10:07 EST
[root@baythorne ~]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.30-4
Package mgetty-sendfax requires mgetty = 1.1.30
Package qt2-devel requires qt2 = 2.3.1-13
Package spamassassin-tools requires perl(Mail::SpamAssassin::NoMailAudit)
Package spamassassin-tools requires perl-Mail-SpamAssassin = 2.63-1
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.33-9.fc6
Package ORBit-devel requires ORBit = 1:0.5.17-19.fc6
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.33-1
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.33-11.fc8
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.30-2
Package mgetty-sendfax requires mgetty = 1.1.30
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.31-2
Package mgetty-sendfax requires mgetty = 1.1.31
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.33-3_FC4
Package avahi requires libexpat.so.0
Package mgetty-sendfax requires config(mgetty-sendfax) = 1.1.30-6.1
Package mgetty-sendfax requires mgetty = 1.1.30

It seems to be mgetty-sendfax which is causing the problem. Adding 'print pkgtup' and 'print self.searchPktTuple(pkgtup) to matchPackageNames() in packageSack.py gives me...

[root@baythorne ~]# yum  update mgetty-sendfax
Plugin "downloadonly" uses deprecated constant TYPE_INTERFACE.
Please use TYPE_INTERACTIVE instead.
Loaded plugins: downloadonly, refresh-packagekit
Setting up Update Process
('mgetty-sendfax', 'i386', '0', '1.1.30', '4')
[]
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 104, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 339, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 195, in doCommand
    return base.updatePkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 577, in updatePkgs
    self.update(pattern=pattern)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 2516, in update
    (e, m, u) = self.rpmdb.matchPackageNames([kwargs['pattern']])
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 211, in matchPackageNames
    exactmatch.append(self.searchPkgTuple(pkgtup)[0])
IndexError: list index out of range
Comment 4 David Woodhouse 2008-11-15 11:14:00 EST
Weird....

[root@baythorne ~]# rpm -q mgetty-sendfax
package mgetty-sendfax is not installed
[root@baythorne ~]# rpm -qa | grep mgetty
mgetty-sendfax-1.1.30-4.i386
mgetty-sendfax-1.1.31-2.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-sendfax-1.1.33-3_FC4.i386
mgetty-viewfax-1.1.33-11.fc8.i386
mgetty-sendfax-1.1.30-6.1.i386
mgetty-sendfax-1.1.33-11.fc8.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-voice-1.1.33-11.fc8.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-1.1.33-11.fc8.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-sendfax-1.1.33-9.fc6.i386
mgetty-sendfax-1.1.30-2.i386
mgetty-sendfax-1.1.30-4.i386
mgetty-sendfax-1.1.33-1.i386
Comment 5 David Woodhouse 2008-11-15 11:18:23 EST
After removing them all manually (rpm -e --allmatches did nothing) I can update.
That wasn't the problem I expected you to care about though -- I'd guessed that was probably something strange about my machine. The one I expected you to look at was...

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
xorg-x11-drv-magictouch is needed by (installed)
xorg-x11-drivers-7.2-9.fc8.i386
Complete!
(1, [u'Please report this error in bugzilla'])


(Which I 'solved' by rpm -e --nodeps xorg-x11-drv-magictouch)
Comment 6 James Antill 2008-11-15 12:45:54 EST
> That wasn't the problem I expected you to care about though

 Ahh, sorry that wasn't obvious.

 xorg-x11-drv-magictouch-1.0.0.5-5.fc8.i386 is obsoleted by xorg-x11-server-Xorg, and you did (basically):

yum update org-x11-server-Xorg

...which looks like a slightly different iteration of 470440, fixed upstream.
Comment 7 Fedora Update System 2009-01-12 14:20:22 EST
yum-3.2.21-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.21-2.fc10
Comment 8 Fedora Update System 2009-01-12 14:28:12 EST
yum-3.2.21-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/yum-3.2.21-2.fc9
Comment 9 Fedora Update System 2009-02-04 21:18:37 EST
yum-3.2.21-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-02-04 21:25:50 EST
yum-3.2.21-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Kev 'Kyrian' Green 2009-02-07 13:05:52 EST
I have just written a fairly exhaustive post on this bug (and it's "predecessor" as it were) here, which may assist users, or bugzilla folks:

http://forums.fedoraforum.org/showthread.php?p=1162410#post1162410

Thought I should add it here, and I'll poke it in the direction of the YumUpgradeFaq too.
Comment 12 Kev 'Kyrian' Green 2009-02-07 13:07:01 EST
Bugger. I forgot to mention, the above applies on a machine that has been upgraded to FC10, so that may negate the 'nextrelease' flagging, but that's up to you folks.

Note You need to log in before you can comment on or make changes to this bug.