Bug 471739 - Can'
Can'
Status: CLOSED DUPLICATE of bug 471741
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 08:16 EST by m.cencora
Modified: 2008-11-15 08:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-15 08:28:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description m.cencora 2008-11-15 08:16:39 EST
Description of problem:
I'm unable to install Fedora on precreated software RAID1 partitions.

Steps to Reproduce:
1. Create software RAID partitions before starting Fedora installation.
2. Run installer.
  
I created software RAID1 partitions in Ubuntu, then run Fedora installation. At first it didn't even recognize those partitions. I found out I need to mark those partitions as 0xfd to make them show up in anaconda, but then another problem arised.
When partitions are marked as 0xfd(linux software RAID autodetection) the kernel sets them up as /dev/md_d[0-n], but anaconda is trying to use /dev/md[0-n] names.
I tried disassembling kernel created md devices, then selected custom layout in anaconda, and chose md partition as root. After confirming the layout anaconda rereads partition tables (even though partition layout didn't changed) which causes kernel to recreate and assemble raid devices under /dev/md_d[0-n] names.
In the same time anaconda is trying to assemble the same raid devices under /dev/md[0-n] names.

Example:
my RAID partitions:
/dev/md0 RAID1 (/dev/sda1, /dev/sdb1)
/dev/md1 RAID1 (/dev/sda2, /dev/sdb2)
/dev/md2 RAID1 (/dev/sda5, /dev/sdb5)
/dev/md3 RAID1 (/dev/sda6, /dev/sdb6)

After confirming the layout it looks like this:
/dev/md0 RAID1 (/dev/sda1, missing)
/dev/md1 RAID1 (/dev/sda2, missing)
/dev/md2 RAID1 (/dev/sda5, missing)
/dev/md3 RAID1 (/dev/sda6, missing)

/dev/md_d0 RAID1 (missing, /dev/sdb1)
/dev/md_d1 RAID1 (missing, /dev/sdb2)
/dev/md_d2 RAID1 (missing, /dev/sdb5)
/dev/md_d3 RAID1 (missing, /dev/sdb6)

So anaconda assembled RAID partitions are degraded and installation is aborted.

I tried adding raid=noautodetect to kernel boot up options, but kernel still created /dev/md_d[0-n] devices automatically. And when I mark partitions that are part of RAID devices as i.e. 0x83 or 0x82, they won't even show up in anaconda during custom partition layout creation. So in the end I'm unable to install Fedora on software RAID devices.
Comment 1 m.cencora 2008-11-15 08:28:20 EST

*** This bug has been marked as a duplicate of bug 471741 ***

Note You need to log in before you can comment on or make changes to this bug.