Bug 471742 - SELinux is preventing amarok from loading /usr/lib/sse2/libx264.so.61 which requires text relocation.
SELinux is preventing amarok from loading /usr/lib/sse2/libx264.so.61 which r...
Status: CLOSED DUPLICATE of bug 471878
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 09:30 EST by Dean Mander
Modified: 2008-11-17 15:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 15:41:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Mander 2008-11-15 09:30:55 EST
Description of problem:
bug in x264-libs, but is it possible to support it in selinux-policy?

Version-Release number of selected component (if applicable):
x264-libs-0.0.0-0.17.20080905.fc10.i386

selinux-policy-3.5.13-20.fc10.noarch
selinux-policy-targeted-3.5.13-20.fc10.noarch


How reproducible:
listen mp3s with amarok.

Raw Audit Messages:
node=localhostage type=AVC msg=audit(1226743559.104:18): avc: denied { execmod } for pid=3140 comm="amarok" path="/usr/lib/sse2/libx264.so.61" dev=sdb5 ino=700335 scontext=unconfined_u:unconfined_r:unconfined_t:s0 tcontext=system_u:object_r:lib_t:s0 tclass=file node=localhostage type=SYSCALL msg=audit(1226743559.104:18): arch=40000003 syscall=125 success=no exit=-13 a0=364c000 a1=87000 a2=5 a3=bfd0ede0 items=0 ppid=3050 pid=3140 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=2 comm="amarok" exe="/usr/bin/amarok" subj=unconfined_u:unconfined_r:unconfined_t:s0 key=(null)
Comment 1 Daniel Walsh 2008-11-17 15:41:04 EST

*** This bug has been marked as a duplicate of bug 471878 ***

Note You need to log in before you can comment on or make changes to this bug.